Door Strike Draft

Hello I am completely new to Sketch-up. Except for high School drafting I have no experience. I was looking for a cad alternative to draft a plan for a door strike. I had imagined I would draw the basic shape then add the dimensions manually and be done. My model is a 3 mm thick 39 mm wide 800 mm long door strike. There are 2 cut outs for dead bolts and 3 holes for screws. I am able to draw the basic shape but when I use the dimension tool to define the dimensions it displays in meters instead of millimetres. Also when you adjust the drawing the dimensions adjust accordingly but if you enter the dimensions the drawing doesn’t adjust to the new dimensions. It seems impossible to drag the size to a precise dimension like 38 mm. Also even after setting a scale 3:1 paper to model the 800 mm is way to long for the paper and can only be seen when zoomed out all the way.

Am I missing something? It isn’t intuitive and even after reading the help files it seems there is no easy solution.

Any guidance is much appreciated.

So it sounds like you’ve drawn your model in meters instead of millimeters. You can change the units to millimeters under Model Info>Units.

Probably the easiest way to resize the plate to the correct dimensions is to use the Tape Measure tool to measure between two points at a known distance. click at each end. then type the correct distance and hit Enter. Answer the question about resizing the model and then use Zoom Extents to zoom in to the new, correctly sized plate.

If you are going to use millimeters as your normal unit of measure, you should modify your starting template to use them. to do that, open a fresh drawing, change the units as above and then immediately use File>save as template to save it making sure it is set as the default. Actually, you might find it useful to zoom in toward the origin first. Draw a rectangle about the size of what you would normally draw. Zoom in on it and then delete it. (there’s no need to have the rectangle in every new drawing your start.) Then save it as your template.

After rereading your post, it is clear to me that you have some fundamental misconceptions about how to use SketchUp.

Under most circumstances you draw at 1:1. If you draw a line that is 1 meter long, that’s how long it is in the model space. there are exceptions to drawing at 1:1, especially when drawing small items. Then it makes sense to work at a larger scale and scale down afterward.

The Dimension tool only reports the dimension between points or the length of an edge. You can edit the dimension but that is only changing one the text says. Changing the text does nothing to the model and it isn’t supposed.

The Scale tool and Tape Measure tool can be used to resize the model. I find it usually easiest to use the Tape Measure tool as I described when I want to make the model a specific size. You can also use the Move tool but I doubt that’s appropriate in this instance.

You would probably find it useful to spend some time going through the tutorial videos offered on the SketchUp site.


Thank you very much for the reply. I will give it a go after work tomorrow. Also thank you for the private message regarding the forum navigation!!!


Thanks again for the reply. I had a look again and realized I am using Layout not Sketchup. Maybe I should draw it in Sketchup then transfer it to layout?

I was able to adjust the dimensions to mm using the dimensions setting in the right hand side tray but couldn’t find a measure tool.

If the 2D drawing in LO is sufficient then there’s no point in redrawing it. But, if you’re drawing it in LO, you are drawing in paper space. I guess I’d draw it in SU and send it to LayOut.

LayOut? That makes a big difference.

I thought you were working in SketchUp and the instructions I gave were
based on that.

Im in Sketchup now. I saved the template. When using tape measure tool I can enter a dimension and see it in the bottom right but when I hit enter nothing happens. Very sorry for the ignorance on my end.

I’ll send a PM. Hang tight.