Document show up when I start the program


#1

I have SketchUp 7 and suddenly a certain document/project/house I have made opens up every time I start SketchUp. How can I change this?


#2

It sounds like you saved it as a template, and now it is the default startup.
Change the startup template to something you want.


#3

Thank you so very much!


#4

And how do I make it so I have no template at all?

(When a so called template pops up when I start the program it’s an older one than my latest changes. I don’t really understand what this templates mean. I’m bad at english too.)


#5

You have to have a Template, it is the basic setting for your workspace and SU needs to know what you want when it opens.
If you open a saved model it should open however you last saved it.
If you open a new blank workspace it will open with the Default Template.
You can choose the template you want to use when in a model by going. Window/Preferences/Template and choosing the one you want there. Select one, then close and reopen SU and it will be the new one.

You can also edit it to make your own default startup template.
Make any changes you want to the settings of the blank model, adjust the style, the units and precision, the time of day, line style, endpoints etc etc even have a simple starting floorplan if you wish. Often good to have a figure in there so you have some idea of scale.
Simply set it up as you would like to have it whenever you want to start a new model.
Be sure to delete and purge anything you don’t want saved in the template.
Go Window/Model info/Statistic and click purge unused.
Then Go File/Save as Template Give it a name, and a description if you want, and save.
So now, unless you choose another, this is how a blank model will open for you.
It will not affect how previously saved models open.


#6

What are templates and how do I change the default template?
http://help.sketchup.com/en/article/38607

Selecting a Template
http://help.sketchup.com/en/article/114041

Creating a Template
http://help.sketchup.com/en/article/114916

Automatically loading a template
http://help.sketchup.com/en/article/114911


#7

So I guess I have to save the projects I usually work on as template every time I stop working with SketchUp?

Can I have more than one template? Because I usually work with three different documents (three floors in the house).

Sorry, but I still don’t understand why the template have to open every time I start.


#8

You don’t need to save a template every time you stop working. They should be the basis for all your new files but saving doesn’t update them unless you explicitly use the “save file as a template” feature (which is only necessary if you want to set up a new template). If you’re finding that your templates update without you intending, is it possible that you have set up a short cut key for the save as template feature?

Check out Geo’s links to the help articles, they will answer all your questions.


#9

But why does this template always open every time I start SketchUp? Can I choose all those three documents I always work on to open when I start SketchUp instead?


#10

It sounds like you’ve disabled the “Welcome to SketchUp” dialog which allows you to select your template. Go to the Help menu, Choose “Welcome to SketchUp…”, then check the “Show on start up” option. As you create templates they should be selectable in the list.


#11

Yes, but you can only add one at a time. I can live with that. :slight_smile:


#12

The quickest way to change templates while you are working is to use the Preferences -> Templates panel. There you can select a template and then hit Ctrl+N (CMD+N on the mac) to start a new file with the selected template.


#13

Okey. Is it possible to delete old templates? I have so many old ones in my list. :slight_smile:


#14

You can delete unwanted templates from the folder they are stored in. Check out the 2nd part of this knowledge center article for the locations of that folder on various platforms - http://help.sketchup.com/en/article/38607