Startup drawing other than template?


#1

Whenever I start sketchup from my shortcut or from windows menu the drawings opens with a cylinder at the origin. I think this is something I created at some point. The object is not in the template file. If I start a new drawing from within sketchup it doesn’t appear, only if I open a new instant of sketchup. I have tried using different templates but get same results. Is the another drawing that is used on startup?


#2

If SketchUp crashed it may start up by reloading the file that was open when it crashed. But this sounds more like you did save the cylinder in the template that is loading as your default. Try starting a new, clean model with no geometry at all (and set up with the camera and style the way you like) and do Save As Template. Make sure the use as default box is checked.


#3

I have already tried making a new template. It opens fine from the new button inside sketchup. It only occurs when you initial start sketchup. I even went and set default template to a stock template and it brings the cylinder on top of the template. I know it is not buried in the default template. Weird. I thought might have missed something. Just started using sketchup a couple months ago. Have used Autocad for last 25 years.


#4

With those added details, what you describe sounds like SketchUp is failing to set your new template as the permanent default. I’m a Mac user, so I can’t explain with any certainty what issues could cause that for you, but here’s one possibility: when you installed SketchUp did you right-click the installer and select “run as administrator”? If not, there may be a permissions problem that is preventing SketchUp from accessing the part of the registry where it stores the path for the default template.

Maybe one of our Windows gurus will chime in with a known explanation…