Disappearing texture

I’ve modelled a house and the adjoining swimming pool. I can see the (semi-transparent) texture on the surface of the pool, when viewed in 3d, but as soon as i change to an orthogonal plan view, the texture disappears.
I’ve checked everything i can think of but can’t fix it. I really want the water “texture” to appear in the plan view, but it won’t.
The strange thing is, I’ve done this before and it worked ok. And I actually copied the water texture from that previous model to save making it again. In the old model, the texture is visible in 3d and in plan.
Any thoughts anyone?

Are those things flat faces laying on another flat face? Looks like the larger flat face is winning in the graphics card display. What happens if you move those objects up say 20 or 30 mm above the ground face.

Good call.
I don’t think so, but i’ll check.

1 Like

confusing. I moved the water group up 10mm… no luck. i tried 100mm, still nothing. So i tried 1000mm and it appears!!! No idea why.
There is a cutting plane for the plan, but that is further up, (maybe 1500mm higher than the pool level) and turning it off and on makes no difference

There is a pool surround group, which has a recess cut into the centre, forming the pool. The water surface is then a flat plane group sitting in that recess, 150mm down from the top.
Or at least, if its 150mm down from the top, the texture disappears.
If its 10mm down from the top, the texture disappears.
If it’s 5mm above the top of the pool surround (which would be overflowing!!) the texture appears!!

at this point, if you want good ideas, you’ll have to share your file. at least the exterior, (we don’t need the house, just the pool / terrain)

either drag the skp file in the text area here, or use wetransfer

It’s solved thanks!
Just for info - I did a stupid thing ages ago which caused the problem.
To elaborate - long, long time ago, i posted on here because i was getting a thin line around the edges of views in Layout. It didn’t print, but it really bugged me that it appeared on screen and I asked if anyone else had it. It seems it might be related to the graphics card in my mac because no PC users had the problem.
Anyway, in my efforts to fix it, i turned on the ground plane in Styles, and made it white. (What I should have done it made the background white).
Anyway, anyway,
The white ground plane was clashing with my swimming pool water texture. If I moved it below the ground plane it disappeared, but if i moved it up it appeared again; in plan views.
In 3d views the ground plane is transparent so i could see the water!
Confusing, but as I say, now solved thanks!