Disable origin in group/component?


#1

Upgrading from SketchUp 2015 to 2017 I am have problems with the accuracy of the endpoint of a group/component I select when using the move tool. With the addition of the origin in group/component endpoint I find that it has a priority in your selection when the groups/components endpoints/midpoints are in close proximity. Many of my models have geometry endpoints that are now in close proximity with the addition of the origin endpoint. In SketchUp 2015 and earlier I only had to zoon into a certain extent to select the endpoint I wanted. In 2016/2017 with the addition of the origin endpoint I have to zoom in much, much closer than in the past to accurately select the intended endpoint. The other workaround I have used is to shift the group’s/component’s geometry away from the origin point. Putting in more distance from the origin point allows me to easily select the endpoint I intended with selection behavior like SU 2015 and earlier. Is it possible to disable the origin in groups/components endpoints?

Edit: I have three images but new members can only upload one image per post so I will add the two remaining images in separate posts.


#2

Although the origin will highlight when you hover over a corner of the group or component as shown, it doesn’t prevent you from picking the corner you want to grab. There isn’t anyway to disable the inferencing.


#3


#4


#5

I do not want to disable inferencing, I just want to disable the group/component origin point that is interfering with the normal endpoint/midpoint selection for me.


#6

OK. You still can’t disable it.


#7

#8

Have you considered to place the axes of the component on the endpoint?


#9

Adjusting the group/component axes is a lot of extra work that I would like to avoid. An average model might have hundreds of these that I would need to adjust. I mentioned to a colleague that I had reached out to SketchUp support about the addition of origin points in 2016 and on. Before I had a chance to explain my issue he mentioned it was a regular nuisance for him. We were both trying to figure out how the origin point would be useful especially at the expense of hindering inferencing that worked really well in the past. For us the addition of a way to turn off the origin point in preferences would be the ideal solution. The other option would be a plugin to disable it. Are you aware of any plugins that exist that could do this?


#10

Even with an extension/plugin

Btw, you change the axes ones for each component…


#11

It would be easier for me to write a plugin to turn of origin endpoints once and for all than to go through all of my libraries and fix each and every component and do that to every new model going forward. I say that too without ever have attempted to develop a plugin.


#12

I’m curious how far you have to zoom in, I have made gifs along the lines of your examples.
Both boards are 1/4 inch and are different components with their origins on opposite sides and they are not in the same plane, I have no problem at this zoom level to select the endpoint of one and snap it to the endpoint of the other.
Origin

Here I have added 3/64 to the side of the component and set the origin to that and again have no problem to grab the endpoint and snap it to the other endpoint.
Origin2
It’s worth noting that these gifs are magnified also.
So if you are having difficulty at around this zoom level I wonder what is different on your system.


#13

You might try using/enabling the “crosshairs” as the cursor (window/preferences/drawing) as this will help you inference your preferred geometry better to get the point you need?
Like Box says, in similar setup I am not finding it hard to choose one from the other.


#14

How about using TT’s Axes tools?


#15

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.