Dimensional errors in sketchup due to way circles are generated

I am new to Sketchup. I am a mechanical engineer used to the big name CAD program.

I am currently trying to model piping for fabrication. Unless I am missing something, the only wall to model piping elbows to to draw an arc, draw the appropriate OD and ID at one end of the arc, then due a “Follow Me” command to trace the OD and ID around the arc.

Since Sketchup creates arcs and circles as linked line segments, I am getting two different problems.

First, my finished elbow might not have perfectly square ends. The ends (OD and ID of elbow) are perpendicular to the ends of the arc, so unless the ends of the arc are at a line segment’s midpoint, the ends go off at an angle).

Second, I can get dimensional errors in the finished elbow. For example, a 6 inch, 90 degree elbow is supposed to have a radius of 9", but if I use 24 sides for my arc path and diameter circles, I end up with a finished elbow that has a radius of about 8-7/8". This difference is significant when we are trying to pre-fabricate welded steel piping for field installation.

Am I just missing something or is there a better way?

When I need to create things like your pipe elbows, I start with a circle instead of an arc and then quarter it at the mid-points of segments 90° from each. This makes the ends of the elbow square to the ends of the path rather than projections to square.

And if I need more precision, I increase the number of segments in the path. The rear elbow in this image was made starting with a default 24-sided circle. The near one was made starting with a 96-sided circle.

1 Like

You may wish to save yourself some frustration:

1 Like

My description might not have been great but this is exactly what I was doing (drawing a circle and drawing lines to get a quarter-circle arc).

I am looking at the trial version, but I was unsure if my small, tight budget company would be up for it (since up-front money is the reason for Sketchup being used in the first place).

… except that SketchUp Make is licensed for non-commercial use only.

Pipe fittings are manufactured with a small (or not so small) straight outside the tangents to ensure that joints fit square. I think you hardly ever (never) see a pipe elbow with the curve tangency right at the very end of the fitting.

Look at this old gem I found on the internet. Its a pdf that’s just like a hard copy I used to have:

You’ll notice that even this short radius elbow has a small straight outside the tangents.

The point is, if you model your elbow using a path that is the exact centerline of the elbow, that’s all FollowMe needs to make that last miter, and your model will be fine.



Search 3D Warehouse for Piping components:

Search Extension Warehouse for all Piping extensions:

I am using Coolpipe and it works great. Just i don’t tested this hardly.
The author seems be making an effort to turn coolpipe on a good plugin

Website on original language: coolpipe.ru
Direct link for download: version 1.3

1 Like

Is there an English Version of Coolpipe?

I lived in Cudahy, home of Ladish Forge since 1912, and they’re still hammering away.

I began my 30-plus year stretch in LA working as a piping designer for two years in a test facility for nuclear reactor components. (This gig ended shortly after the Three Mile Island fiasco.) We designers all had our Ladish catalogues, and we’d sit there all day drawing piping isos, our instruments clicking and clacking against the blades of our drafting machines. I hated going home at the end of the day.


Yes, @durrroy. Just change the language.

OK thank you, I will give it a try.

I unzipped the folder which is a rb. file. How do I load a rb. file or convert it to a rbz. ?

If your SketchUp version is 8M2 ou higher just install the .RBZ file on menu Window > Preferences > Extensions > Install Extension button. Don’t need to unzip the file.

If your SketchUp version is lower than 8, unzip the .RBZ file and put the unzipped .RB file and folder on

C:\Program Files\Google\Google SketchUp 8 - 7 or 6 VERSION \ Plugins

One of the things to remember is that because SketchUp’s arcs are segmented “followme” extrusions like pipes will always start perpendicular to the selected path.
If you path starts straight and then has an arc part as a bend, then all is OK.
But if you start at an arc, but are not perpendicular to the first segment, then the extrusion will probably be skewed.
I exaggerate the segmentation in the following example…


More plugin links in the pipe-lover section.

You are right (see my first problem). I figured out that if the arc had segment midpoints right on the red and green axis then everything was good.

Check the extension warehouse for a plug in called “pipe along path” you can set the inside and outside diameters in either millimeters or inches. You select the path (line or curve), set the ID, OD, number of segments, and click OK and you have your pipe.