Dimension tool not spanning the whole model

Hello, I have a strange problem where when I try to add a dimension to certain models, it will not select the whole model. See screenshots. This drawing was created on another machine and it does appear to only happen on existing models not new one. These are basic rectangles and have no extra lines or points connecting to them. if I select corner to corner the dimension works, it’s only when I select the whole edge line.
Thanks! Matt



Share the SketchUp file.

Looks like the edges have been split for some reason. Seeing your file would help us help you.

Thanks. Sorry, meant to attach it to the original message. Here it is.
Kitchen - Multiple Iterations.skp (3.4 MB)

Edited: I am seeing the same thing although it’s the first time I see such a thing when the edges have not been divided.
dimension

I do not quite a lot of incorrect tag usage …
Screenshot - 10_16_2023 , 2_18_41 PM
And plenty of unused stuff to purge.
Screenshot - 10_16_2023 , 2_18_59 PM

Yeah, same file. I just realized that the dimension isn’t there when I exit the group edit. I don’t think I mentioned that it only happens when I go into edit on a group (3d rect)
I just did this one on that file.

Looks like you’re using ConDoc Tools. I wonder if it has anything to do with that.

I copied your group to a new file and tried adding dimensions. No problem.
dimensions

See if this file behaves better for you. It does for me.
Kitchens.skp (2.9 MB)

Yep, that’s working fine. I’ll just have to make new copies of everything.
Thank you very much for your help!

Matt

It would be interesting to understand what’s going on. I don’t use ConDoc Tools and I wonder if this is somehow causing it for you.

Is that the Trimble Connect extension?
I disabled Dynamic Components and Sandbox tools just to check them, and now neither will enable again :man_facepalming:

Scratch that… I had to enable each individually and it worked

It’s an extension that you can get via the Extension Warehouse. Search | SketchUp Extension Warehouse

There’s a tag called CONDOC_3D Object that made me think you are using ConDoc Tools. Maybe it’s an object you got from somehwere else.

Ah, yeah it looks like that is the name of the sink model I got from the warehouse.

Ah… Well, it’s a curious thing. Keep your eyes open for it to happen again.

Will do, thanks again

1 Like