Dimension Font Help!

pdf
dimensions
font
2d-export

#1

Hi guys!
It seems I’ve made a terrible mistake by deciding to change the fonts used in my dimensions… Now when I export to PDF from sketchup, the resulting PDF won’t open in Acrobat or Indesign. It does open in Photoshop, for some reason, but then when I save it as PDF from Photoshop the file is huge! 17KB file turns into 4.8MB despite me not editing it at all & saving with no layers & “Preserve PS Editing Capabilities” turned off.
Ideally I just want to be able to export to PDF direct from Sketchup & leave it, be able to open it in ID & Acrobat with no errors. I don’t really give a sh*t about the font anymore! Problem is I don’t know how to revert the dimensions font back to its default setting. The font change seems to have effected all my files & any new files I start… Is there a way I can revert it to default?
Any help is really greatly appreciated!!!

Cheers

Ethan

PS It is probably also worth mentioning that the issue doesn’t occur when I export to PDF via layout, but that sometimes causes dimensions to disappear at random & is an unnecessary extra step in the export. If there’s a way to change fonts to default, or fix the PDF export settings that’d be ideal…

Here are the error messages:
CaptureCapture2


#2

This, from the Adobe Systems Acrobat Users Forum Archive
Q | What is a bad /BBox ??
https://answers.acrobatusers.com/what-bad-BBox--q235336.aspx


And this September, 2015 post in the Adobe Systems Forum directly mentions SketchUp
Q | The font ‘Tahoma’ contains a bad /BBox.
https://forums.adobe.com/message/7987985#7987985


I notice the same error in SketchUp Pro 2018
File > Export > 2D Graphic > Save as type: PDF … Under the Options button > Defaults


Below are the Document Properties when opened in Adobe Acrobat Standard.
Notice the PDF Application: A ClibPDF program
Notice the PDF Producer: ClibPDF Library 2.02-r1-2 Windows 9x/NT
Apparently, the PDF Producer is the root of the problem.

Perhaps @Barry can help us understand what’s wrong.



Here’s what I can find about ClibPDF Library 2.02-r1-2 Windows 9x/NT

ClibPDF Library Reference Manual [Manual version 2.01-r2; October 16, 1999]
Copyright ©1998,1999 FastIOTM Systems, Inc., All Rights Reserved.
http://www.homer.com.au/webdoc/pdf/cpdfman200.pdf

About ClibPDF by FastIO Systems
http://www.planetpdf.com/mainpage.asp?WebPageID=446

About - FastIO Systems, Inc
https://www.ca-registry.com/C2146469-fastio-systems-inc


#3

Checking with others, not currently my area…


#4

Try the following:
In the Export dialog, click on the Options button.
Check “Map Windows fonts to PDF base fonts”.
Click OK to save and now try exporting.

Does this solve the issue?


#5

OK … I’ll try that.

Indeed, it does. Thank you Stacy!

Just out of curiosity, why wouldn’t that be checked when the user hits the Options > Defaults button?


#6

Geo - I don’t know the answer to that. It looks like that setting is not impacted at all by clicking on “Defaults”. If it’s checked and you click Defaults, it remains checked and vice versa. We do have an issue in our internal database that I have added a note to for further discussion.


#7

Open any SketchUp model file.
There, look to the top menus and click… File > New
What you now have open in SketchUp is your Default Template.

Now click… Window > Model Info > Dimensions
There, you can change the Dimensions Text font and other dimension settings.

Then, look again to the top menus and click… File > Save as Template
Confirm the Set as Default Template box is checked in the Save as Template dialog.

See:
Setting Up Templates — SketchUp Help


#8

My test of the SketchUp PDF exporter resulted in finding a possible bug: The exporter doesn’t seem to support non-ASCII characters. I created a text with some “ä” and “ö” characters (umlauted, very common in Finnish) and got this:
image

Checking the “Map Windows fonts…” box results in the same gibberish, but with Arial switched to , apparently, Times.
The /BBox error is generated regardless of the font, even with Adobe fonts.


#9

Yes!! This solves the issue!! Thank you so much Stacy!!! It looks like the box won’t stay checked on all files, but at least it’s easy to do & once checked in a file it seems to remain checked for that specific file, which is great! Thanks everyone for all your help & input with this!

Yep, I had the same issue - I first had it set to Helvetica, but also tried Arial, Times New Roman, Tahoma & about 4 others, all of them came up with the same error message… Thankfully I don’t have to contend with any umlauted characters because I’m only using dimensions at this stage, so as long as the numbers & letter ‘m’ work I’m fine! Hopefully you’re able to find a work around for the umlauted characters, though!!


#10

Thanks, Geo - this method is exactly how I got myself into this mess in the first place!! See, once you change the fonts, there doesn’t seem to be a way to get the program to revert to whatever it’s default font was at the time of installation. Whatever that fresh-install default font was worked perfectly fine when I did a 2D PDF export. It was only when I changed the font to anything other than that original default font that the issues started. From what I gather, the default font is not one you can choose from that menu, or if it is then all of my guesses as to what that font was called were wrong! haha


#11

The default font for SketchUp on Windows OS is Tahoma.


#12

Oh right! Well that makes it all the more strange that when I set the font to Tahoma it came up with the error message then…? It never gave me these error messages prior to me trying to change the font from the original default to Helvetica. After that nothing seemed to work… Very, very weird… Thankful for a fix though!


#13

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.