"Bad /BBox" Font error when exporting as 2D pdf

When ever I export a 2D image to pdf that includes dimensions or labels, will get a “The font 'Tahoma” contains a bad /BBox.

I have tried different fonts and get the same result. Anyone have a solution for this (other then not using labels)

James

When you installed SketchUp, did you do it correctly? That is, did you right click on the installer exe file and choose Run as administrator? Weird things can happen if you don’t. There are numerous threads that include the whys so I won’t repeat them.

Do you have Acrobat or Acrobat Reader installed?

Sketchup is running as admin. I use acrobat X. Have seen the same error come up on other devices using reader or full versions of acrobat.

I have had this similar problem since 2015, It is more an annoyance then anything as once error is cleared when opening the pdf it is fine.

That’s not the same as installing SketchUp with Run as administrator. At least to remove any question, you should close SketchUp, find the installer exe, right click on it and choose Run as administrator. Then choose the Repair option when it presents itself.

The error message you are getting has to do with Adobe seeing one of more bad glyph bounding boxes. Do you get the same error if you create a PDF from LayOut?

1 Like

I have rerun the installer as admin, and ran the repair installation. The issue is still showing up. I then uninstalled sketchup 2018 and reinstalled as admin and the issue continues to occur.

I do not get this error when I export to pdf from layout.

Hello

I have the same problem but not only for PDF, also JPG.

This is my model :

this is what I get when I export to PDF

And this is what I get when I export to JPG

I uninstalled & reinstalled Sketchup 2018 pro. No change.

There was a previous yet closed topic about it, that suggested to tick map windows fonts to pdf base fonts that removes the bbox error but won’t show any accent such as é à è that I need in french.

here : Dimension Font Help!

I recently changed the font in model info, and I have the problem since then. No patch since the problem has been pointed out ?

What font?

I tried many fonts, very usual ones, such as arial, times… on the screenshot above it’s the default sketchup font on windows, tahoma

Did you try Stacy’s steps?

You asked about a patch. You can expect that there will be no patches for SU2018.

as I said, I did try but just like the others all the accent won’t show. Plus, it only fixes the PDF export, not the JPG export that shows black areas over text.

I’m aware there won’t be any patch for sketchup 2018, i’m just surprised - if you read well - that there wasn’t any since the problem has been pointed out ( november 2017)

Do you get the same error when exporting from LayOut (using Vector rendering)? Or printing to a PDF printer with the “Use High-accuracy HLR” printing option?

ensure with the graphics settings that the Windos desktop color depth is configured to “True Color” (32 Bit) and not a reduced color depth (as 16/8 Bit).

hello and thank you for your answer, but my color depth is set to true color already. It is clearly a text bounding box bug inside sketchup

1 Like

Here’s how to solve the problem: File > Export > 2D Graphic > Options (on right bottom) > Map Window fonts to PDF base fonts (mark the checkbox at the lower bottom).
It solved my problem. No more annoying prompts for /BBox errors.