DC insert from Component tray LOSE or GAIN

I’m have an issue when inserting a DC from the Component browser tray.

  1. Workflow: Create DC, Save to my cloud folder, right click, save as, save to SU component folder.
    Open new or different file, insert DC from Component browser tray, = lost parent attributes.
    I have tried to save the file to a folder on my pc and then copy and paste it into to component folder in the SU directory. Same result.

  2. Workflow: Insert DC from Component tray(working DC with no issues when inserted), explode, edit to create new DC, select all component, G, edit parent attributes, save new Component name, save to my cloud folder, right click save as to SU component file,close.
    Open new file or different, insert from Component tray= DC comes in wrapped in old parent…?..?explode= returns to desired parent…
    if I import the DC from my cloud file it works as desired.

Try either File/Import to get your DC into a new model, or once you have brought it in, explode it once. Then try again to access its Component Options.

The process you are using to save your Components results in an extra and unneeded component container being created. You could save yourself a lot of gymnastics and trouble if you use the Components panel to save the DC to your collection. Open the secondary pane in the Components panel (button at the top right), set one pane to In Model and the other to the desired collection folder. Then click and drag the thumbnail for the component from In Model to the collection. No extra component level this way so no need to explode or open the component to get to the Component Options.

FWIW, you can save custom styles using this same method and on Windows, you can save custom materials, too.

1 Like