DC dialog (CEF) drop down menu (HTML select elements) do not work

(I seached on the web before posting, but the solutions didn’t work for me)

Hi!

I’m having a problem with the drop down menus of the dynamic components. All the drop down menus doesn’t work anymore (Component Options and Component Attributes).
Is there any other solution that is not related to “windows scaling”?
I tried uninstalling and removing every sketchup folder on my computer, but it didn’t work either.

Obs: Options are still selectable (with arow keys on keyboard), but the menu doesn’t work when I click. Sometimes when I click, change the option with the arow keys and then move the cursor above the list, the list apears, but this is not constant

Sketchup 2019
Windows 10 Home

What version of SketchUp are you using? Your profile says 2019 Make but that doesn’t exist.

What version of the Dynamic Component extension do you have?

When you installed SketchUp, was it done correctly? That is, did you right click on the downloaded installer and choose Run as administrator from the context menu?

1 Like

Hi Dave! Thanks for the reply!

I’m using the 2019 Pro (?) version, but on the 30 day trial.
I saw your suggestion on other post (run the installer as administrator), but it didn’t work.
This is a “Clean” install, without any plugins (I removed everything to make sure it wasn’t any conflicts or something)

What do you mean “it didn’t work”?

Dynamic Components are run by an extension. If you removed it or part of it, that would cause problems.

Quit SketchUp, find the installer, right click on it and choose Run as administrator. Then when presented with the option, choose Repair.

Why would you edit a title correction back to wok when you even use work in your post!

1 Like

Uninstalling sketchup and reinstalling using the “run as administrator”, that didn’t work (I saw this suggestion on another topic before posting)

Oh! I just added some information on the post itself. Didn’t realized that the title was incorect hahahahahaha (sorry, English is my second language)

Tested with a clean install, without removing anything. Downloaded the installer from sketchup.com and tried, but the error still persist

multiple monitors?
high-res monitor with Windows display scaling set above 150%?

reinstall the MS runtime library Visual C++ 2015 required by SU 2019 again, launch the installer by “r-click > Run as Admin…”. Quit all programs before doing this, restart Windows after doing this.

No Multiple monitors
Display Scaling set to 100% (saw this solution on another topic before posting), I even tried to set above 150%, run sketchup, and set below to 100%, but it didn’t work.

Will try reinstaling the runtime, thanks!

In SketchUp, go to Window > Preferences > OpenGL > Graphics Card Details … and make sure the vendor is Nvidia Corp. (Ie, that SketchUp is using your Nvidia GPU and not an integrated Intel GPU.)

Also try changing Fast Feedback and see if this helps. (Ideally you want FF on.)

Hi Dan!

Vendor is ok
Fast Feedback is on

I tried changing the nvidia 3d settings too (“performance”, “quality”, “let the software decide”, etc), but it didn’t work

Okay looks like SU is running on your performance GPU.

Does rebooting the computer help at all?

Rebooting didn’t work either.
Well, I think I’m going to install Skp on a virtual machine for now.
Thanks for your help Dan!

1 Like

I noticed you have the circle click option switched on for your mouse. Does switching that off have any effect?

And do you have any special mouse software installed ? Such as Logitech MouseWare or MS Mouse and Keyboard Center ? (I’m wondering if any mouse settings are inteferring with HTML controls in SketchUp’s CEF dialogs.)

Also do you have any problems clicking dropdown select controls on webpages in normal Chrome browser ?