DC changing timeout "This operation seems to be taking a long time"


I have a DC that takes a little while to do its work…and its driving me nuts to have to deal with SU dialog that pops up:

This operation seems to be taking a long time. Would you like to continue?

Is there anyway to change the timeout setting for this dialog, or worst case, disable it completely?

How about uploading it so someone may examine it to see where the issue lies.

Here you go…when used standalone, it skates inside the timeout…but when in a complex scene, it gets triggered. Love to optimize it — but would also love to change the time window of that dialog setting…
KedrySkye.skp (434.6 KB)

The default is 10 seconds. To change it to 60 seconds, enter in the Ruby Console …


Then the next time a DC is redrawn it will use the new limit setting.

1 Like

Dan - star man. thank you.
Is there a way to make this sticky across sessions…(i.e. ini file setting or somesuch?). Su must read it in from somewhere?


The simplest way is to put it in a (UTF-8 encoded) text file with a “.rb” extension and drop it in your “Plugins” folder. But it must load after the DC extension, so here is a script that ensures that …

su_dynamiccomponents_timelimit.rb (299 Bytes)

Restart SketchUp and the script will be automatically loaded.

If you wish to change the setting, use a good free code editor like Notepad++ or MS Visual Studio Code.

If you don’t know where your “Plugins” folder is, then open the SketchUp Preferences dialog window, go to the Files panel, and click the folder button to the right of Templates. The “Plugins” folder is a sibling folder of the “Templates” folder.

1 Like

Phenomenal. Thank you so much!