.dae not showing up right [Help]

My model appears in SketchUp right, but when I export it as a .dae in Blender, my model doesn’t show up. It shows this in Blender.

Different softwares have different interpretations of where axes should be directed. For example in math class, a graph was like looking through a window with y upwards, and when adding a third axis (z) it would logically be horizontal. In SketchUp, xy is the ground plane, thus z is upwards. Another point is whether a left-hand system or right-hand system is used.

In the Collada export dialog, you find an options button, where you can change the axis coordinate system.

Alright

This is the Collada export dialog. Which one would I click to change axis coordinate system?
a28b1a8b9f43a5e17cf9d88e75dbbce3

I was told, “your model is several objects and only one is being imported. Without more info, that’s the best I can do.”

I’m not sure how to fix this problem.

Sorry, I confused this with “Swap YZ coordinates” in the .OBJ export options. I am wondering why this is missing from the Collada exporter (if the Collada standard is not fixed on specific axis directions).

The obvious way would be to use the Rotate and Scale Tools to manually correct this situation. But I agree, this solution is cumbersome and unsatisfying.

Either in SketchUp before export:

  1. Select everything (Ctrl+A).
  2. Select the Rotate tool and press the left mouse button on the red (X) axis and drag to align the rotation axis along the red axis, then release. Click a point on the blue vertical (Z) axis and rotate it until it is in the horizontal plane (green Y axis).
  3. Select the Scale tool and scale everything vertically upwards and type -1Enter(flipping in Z direction).

Or in Blender after import:
See on StackOverflow: y=z z=-y

I’ll see if there are better solutions or whether this can be automated.

1 Like

Alright

I tried it again, and the issue seems not to be with the axis orientation (Z is upwards in both), but with export/import options:

SketchUp: File → Export → 3D Model… → .dae → Options

  • [✓] Triangulate all faces
  • [ ] Preserve Component Hierarchies
    Other guides say to check this, but at least for this specific model it only works if unchecked. If I understand it right, the model still has nested groups, but component instances of the same definition appear as independent meshes (not linked to the same definition).
  • [✓] Export Texture Maps

Blender: File → Import → Collada (default) (.dae)

  • [✓] Import units

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.