Cutting intersecting grooves into surface


#1

I’m having trouble milling intersecting grooves onto a surface. I can cut one groove, using “intersect faces” function (though I find instructions on it’s use unclear), but when I cut a second groove intersecting it, it doesn’t work. Something always goes wrong. See attached.


How to repair programmatically this crazy face?
#2

If you were to delete the small central square, would it still look wrong? Intersect faces always needs some clean up, and it looks as though just deleting that square face and its edges would leave the shape I think you intend.

Could you post the original SKP file?


#3

From the little I can see in your screen shot, it looks like you could erase a few edges and be done. Don’t forget to correct face orientation.

If that doesn’t work, upload the SKP file so we can take a look at it.


#4

Yes. The entire surface of the disk would disappear.


#5

Erasing anything more doesn’t work for some reason.


#6

Xcut.skp (111.7 KB)

Here’s the skp file


#7

It’s really interesting. I drew something approximating to this, two small cylinders intersected and exploded into the same context as the large cylinder.

Edit/Intersect Faces produces something very similar to the screenshot, and when I remove the parts above the large flat face, the remaining edges of the grooves are not in the same plane as the flat face. If I delete the little square and its edges, the whole face goes.

Same thing happens scaled up 100x (my ‘large’ cylinder was 100mm R, the small ones 25mm R and 50mm long, BEFORE scaling up).

Here’s the SKP file after running Intersect Faces/With model, before attempting clean up.

Test intersection.skp (1.4 MB)

And after removing parts above the top plane:
image
Test intersection2.skp (1.4 MB)

Delete any of the edges of the centre square, and the face fills in again. And as you can see from the thickened cross-shaped outside edges of the intersection, they aren’t in the plane of the face. Furthermore, drawing rectangles ‘on face’ over them doesn’t work either. STILL can’t cut the face.

Even if I select just those edges, and move them on the blue axis ‘into plane’, I can’t get them to cut the face.

Why not?


#8

After my post, I saw OP’s uploaded model. It behaves just the same way.

I embedded both my cylinders of the same size to the same depth, OP’s were differently embedded, but with the same result.

Puzzling.

I simply can’t get it to work. But think it should!


#9

With SU Pro, and Jim Foltz’s Trim and Keep plugin, I have no difficulty in subtracting the cylinders from the original, either one a time or combined into a single solid (after removing internal faces with Solid Inspector2).

Something seems bugged in the Intersect Faces command, unlikely though that is.

Any ideas, @DaveR?


#10

Sorry.At Boy Scout meeting. Will look later.


#11

BTW, I’m using SU Make, not SU Pro.


#12

“It’s really interesting. I drew something approximating to this…”

Yes, this appears to be exactly what I’m doing.


#13

Smells a like a variant of the known bug with inner loops (holes in a face) that meet at a vertex. When I probe the internals of your model, I find that the edges of the “cross” shape report that they are shared by three faces, but only two of the faces seem to exist! That isn’t much help to you avoiding the problem, but I think it is a real bug not something you did wrong.


#14

I know, I looked at your profile. I was only trying it in Pro to see if the problem was in Intersect Faces (which it seems to be) or something in the geometry itself.

I’ve seen it said on the forum that Intersect Faces CAN do anything the Solid Tools in Pro can do, but with more effort to clean up.

Is there a known workaround, then, Steve? I couldn’t find any way of drawing or redrawing the outer edges that would cut the face, either using the Rectangle tool or the Line tool to draw them, or the Move or Move/Copy command to get the lines to cut the face.


#15

Usually redrawing an edge or two will cure it, but that doesn’t seem to work in this example. It is the nastiest I have seen!


#16

After a LOT of fiddling around, I found a way to get it to work in the end.

Delete the whole top face of the big cylinder.
Trim off the internal faces where the two small cylinders join.

Window select the indentation, and move it up a small amount - I tried 0.01mm.

Recreate the top face by drawing over an outside edge.

Redo the Intersect Faces command.

Parts of the cross shape are no longer profile edges (though some still are). Delete the subfaces they make.

Turn on hidden lines. The top face triangulates, and by repeatedly drawing over (using the Shift key to hold an ‘on face’ reference) the borders you want to create ‘in plane’ faces for, then deleting any subfaces that form, I eventually got rid of all of the cross shape top face.

Then Orient faces to get the indents with front faces up.


Test intersection2.skp (1.4 MB)

But what a pain!

PS. And I see by close inspection that the ‘thick’ line in the upper left of the ‘cross’ isn’t a single line still, but i can’t clean it up without opening up a hole.

Though eventually I could see that it was a double line. I moved one on top of the other, and finally got it clean.

… I thought. I see I didn’t quite get the two ‘cutting’ cylinders at the same depth!

And the face is weirdly triangulated.


#17

Sticky one. PushPull is the best bet to get it to work.


#18

Looks like magic! Good one, that.

Why does it work?


#19

The edges are not ‘connected’ to the face. It seems that the pushpull operation causes the geometry to merge.


#20

It seems like a minute discrepancy in the math. I noticed that after the pushpull the plane of the face changed slightly.

Take a look at this @thomthom.

image