Cutlist keeps resizing my parts

Hello,

I was just about to throw my laptop across the room but then i thought i might ask for help prior to resorting to violence! This is my problem: I am using Sketchup 2019 and also using the extension Cutlist. I finished making my model and open up the cutlist extension. I create my materials to match my parts and am all set up. I click the generate button and it generates my part list. However no matter what i do, it resizes SOME of my parts to having the ~ symbol in front of it. For example: instead of 1/2" i get ~1/2". Thus completely rendering my cutlist useless… So I highlight the part that is “material size unavailable,” I edit the part back to the dimension that it started as, open back up cutlist, generate the parts list and the parts that I just changed are fine, BUT NOW several others that were ok are now ~~ ~~!!! I have gone back and forth for hours now and I am about to lose my you know what! Please help! I have tried making every single part unique prior to resizing it to it’s correct dimension and no matter what, If I fix one part, several others resize out of whack. Holy Hell! Please Help!

Thanks,
Mike

There are several things that could be happening. I’ll discuss them below, but if you can share your model here we could take a look and tell you exactly what is going on. One thing you must realize is that cutlist extensions don’t resize your parts. But they may report a different value than you thought you drew.

I’ll assume that the cutlist extension you are using is CutList 4.1. There are others available and they might work slightly differently.

A leading “~” on a dimension in SketchUp and hence also in CutList 4.1 means that the actual size can’t be shown exactly using your display units precision. For example, if the real size is 3 3/32 and you have the display precision set to 1/2, you will get a ~ because the value is rounded to the nearest 1/2. That is, the displayed value is not fully precise. Try increasing the precision in the model info->units panel and see if that helps.

Assuming the precision is adequate, the two most common reasons for getting a ~ in CutList are:

  • You have not drawn the part to a precise size, it is slightly off. In fact, I use the presence of a ~ in CutList as a test for where I might have erred in the model. This happens most often when you drag out a size with the mouse instead of typing an exact value or getting a snap from a reference that is known to be accurate. Sometimes I get a snap from a nearby point instead of the one I intended, and that will throw off a length. I’ve learned to orbit the view to make sure I’m getting the right snap.
  • Your parts are not tightly aligned to their bounding boxes. CutList actually uses the dimensions of the bounding box, as if it is sizing the board from which you would cut that part. If a part is askew within the box or is a complex shape that fits loosely in the box, the reported dimensions may be different than expected. Assuming you are using components, you can right-click, choose “change axes” and bring the axes into alignment with the actual part to get a tight bounding box. Then the dimensions should be correct.
2 Likes

FWIW, Cutlist is not able to resize your parts. It has no control over the geometry. It’s only capable of reporting the sizes of the component or group bounding boxes.

It sounds like you are modeling in fractional units. Set Display Precision to 1/64th in. so you can see the actual dimensions and if it’s on, turn off Length Snapping. Look at your components and make sure the bounding boxes actually fit the geometry and that you haven’t got any stray geometry.

2 Likes

Thanks for you detailed and thorough explanation!! It’s very much appreciated. I went in and changed the units to 1/64 and that sure opened up a whole other can of worms within the project! lol! Let me start by saying that I am brand new to Sketchup and still learning the basics, for the most part. I just figured out how to move things around while keeping them on the same plane… haha! I still havent figured out the secret of using the rotating tool! It takes me clicking and trying 10 different combinations until I get lucky and the part actually rotates the way that I want it to… Just to give a brief disclosure on my skills/knowledge…

I attached the simple model that i am trying to generate a cutlist for. It’s just the drawers for a cabinet project that everything else is done with and these are the last part. All the material is 1/2" and that’s how i modeled them all but again, when i try to generate the cutlist everything goes all whacky for me.

Also, I feel really dumb asking this question, but when you guys are referring to “bounding box” what does that mean? I know this is probably the most basic thing and I’ll feel really dumb after you tell me but I gotta learn somehow. Thanks again!!

MikeDrawers for Cutlist.skp (157.4 KB)

You should be making each distinct piece of the project a component or group so that they don’t all stick together and make editing impossible. Then when you select a component instance or group you will see a blue outline appear. That is the “bounding box”. Ideally it will fit tightly around your piece. When it doesn’t, that’s a sign that something is askew or perhaps there is something extra in the component.

Ok. That’s what I figured the bounding box was… w regards to creating components, that’s what I do. however after the 5th time I resized a part, generated the cutlist to come back to 3 different parts resized differently, I went in and made each one of the drawers/parts unique to try and combat the resizing problem. also, all the parts that were not as intended in the extension all have a flag that says the size was changed… See screenshot. Is that not really the case?

image

At a quick check, it looks like you drew the right hand rabbet on the drawer to an inaccurate depth (at least I assume it wasn’t meant to be 19/64 :wink:)

That dialog box isn’t from SketchUp itself, it must be from some extension you are using. CutList 4.1 doesn’t have that, so it must be something else. Not familiar to me…

You are correct… My bad… but would the rabbet sizing affect the cutlist generation? as when I do generate one successfully, it doesn’t show me the cuts for the rabbets or dadoes.

honestly, I really appreciate your help but you don’t have to continue helping, as I am sure this is all pretty elementary to you… and probably things that I should have to figure out on my own. Feel free to continue but I do kind of feel like I am wasting your time a bit here…

That rabbet size figures into the length of the front and back boards. I also notice that the backs of the drawers are upside down (rabbet for the bottom is at the top) and some of the side boards are 31/64 when I presume you intended 1/2.

We’re here to help and many of the questions are from beginners who are learning, so don’t feel bad about asking. For now, I’d suggest you try fixing the drawers on your own and come back when you have a specific question.

BTW what extension gave you that dialog window? It seems to suggest that you are using the scale tool to stretch a single component for the various size drawers. That can be a problem, because scale acts proportionally on all aspects of a component. For example, if you stretch a length by 5%, the dados and rabbets will likewise be resized by 5%. Scale is best reserved for simple things that have no details that need to remain a fixed size. It is actually pretty easy to resize something like the drawer by using the move tool - though that means each distinct size needs to be a distinct component.

As I wrote before, the cutlist only reports the dimensions of the bounding boxes for the components. It does not report the details you’ve added.

Also as I wrote before, you should turn off Length Snapping. Instead of using Architectural units, you probably ought to use Fractional, too.
Screenshot - 1_25_2020 , 3_34_09 PM

Which cutlist are you using. CutList 4.1 shows this for the drawer next to the blue axis.

Steve made a comment about the groove for the drawer bottom being on top on the drawer back. You rotated a copy of the front end for end to get that. Instead of rotating it, use Flip Along. That will create a mirror image of the component.

It looks like you drew the drawer front laying down on the ground plane and then rotated it up to vertical after creating the component. You can save yourself a lof of work if you draw the parts in the proper orientation from the beginning. Also use the parts you have modeled as guides for the additional parts.

What dimension do you really want for the length of the drawer front and back. Are you really cutting the lock rabbet back like you show?

Steve already mentioned the scaling thing and how that affects the grooves for the drawer bottoms.

Here I’ve modeled the drawer starting with the left side component which was them copied to the right along the red axis. I moved the copy 25 inches since your drawer is roughly 25-1/2 in. wide and the sides are 1/2 in. thick. To create a mirrored copy of the left side, I right clicked on the right side and choose Flip Along>Component’s Red. then I used the sides as guides for modeling the front which was component copied to the back and flipped in the green direction. I’ve made an exploded view showing the component axes so you can see their relationship.

The bottom was modeled using the sides as references for dimensions.

Here’s a little animation to show you what I meant about how scale distorts internal dimensions.

scale

2 Likes

It is an OpenCutList dialog windows :wink:

Thanks. I don’t use that one so I didn’t know. It seems useful though a bit peripheral to creating a cutlist.

OpenCutList is designed for generate cut lists.
There are many options available, very practical depending on the needs.
But you can use this plugin in a basic and fast way using the default settings.
This is the cut list plugin I adopted because it is very complete (texture management, edgebanding management, error warning, works with dynamic components etc…).
And it is regularly updated. And it’s pretty :slight_smile: