Curve driven patterns

i have this basic universal bracket i have drawn up and the hole that is on the top, i would like to copy it all the way around equally. How would i do that on a curved surface? here is a pic of the part along with the file.

thanks again

curve driven patterns.skp (112.7 KB)

hello, you could use the copy along path plugin, or equivalent. It will allow you to copy with an equal spacing.
For a cleaner result, you can give thickness to your component that you want to copy and then intersect them all with the outer face of your curved object, and extrude the “print” it creates.
you’ll also need to tick the option that orientates your component perpendicularly

for info :

Thanks for the answer. It would be helpful for me.

Thank you as well. I have been wanting to make patterns like this but never knew how to go about it.

I watched the video and thats a great plugin. Is there a way to put the poles in the center of the spiral ramp rather than the edge? I guess we would have to have a curve in the center? Maybe show hiden geometry, weld a curve and then use the plugin

the current version of this plugin does not contain the feature they show in the youtube video. The JHS powerbar is missing the copy comps to path feature:(

Ill keep looking for one that will do what i need it to:) thanks

hello, true, the blue tool is missing on mine too.

well you can always rotate your curve so it becomes horizontal and create a group/component that you’ll intersect with your bracket, like this :
01

then use the ‘red’ tool with correct spacing (i did it quickly without calculation causing a larger gap in the middle)
02

put it back on your bracket (or you can rotate the whole bracket at first)
03

intersect or substract et voilà

04

your model is not very clean and also very small, I advise you scale it up a hundred or a thousand times while working on it and then revert once done.

Yeah the file i uploaded, i was experimenting with and forgot to clean it up before sending.

I created this shape by drawing half of it, then copy and flipped. The odd thing is… the arc data got messed up. If you look at the arcs on the top, one will say 9 segments, and if you look at its copied part, it will say 10. Some say 12 as well. I made sure when i created the arcs, that i used 36 or 48 sides. None of this 10, or 9 sided stuff. I dont know why or how su decided to not use the vaules i told it to use. I know in some cases it will tell me number of segme ts ia to large for radius, but it never gave me that warning.

Thats funny that you did the rotate way as well. I started messing around with that option to. I also found if you go to help>cadfather you can turn on the other tools…

Thanks

Perhaps the following explains the unexpected segment counts: if you draw a new edge that attaches somewhere in the middle of an arc’s existing segment, that segment now turns into two segments.

Consider a hexagon, created as a six-sided circle or polygon. Select the perimeter of the hexagon, and Entity Info should show a circle or polygon with six segments. Now draw a new edge that attaches to one of the existing six segments of the hexagon, and goes off to the side somewhere (doesn’t matter where). With the perimeter of the hexagon still selected, the Entity Info window will now show seven segments. If you delete that extra edge, I think the perimeter will still show as seven segments - the two co-linear pieces of the original segment that was broken into two when the stray edge was added do not automagically weld themselves back together.

I wonder if in your ongoing edits of the model, some such edges were drawn attached to some curve segments, which divided them.

1 Like

hmmm, that could be it. because when i first drew it, it was exactly the way i wanted it. I then copied the lines, pasted them, then flipped them to make a mirror image. None the less, the arcs have become very mixed up haha.

Plus, when i created this, i didnt think that it was to small for SU to handle. But im wondering, like paul has mentioned, that maybe it is to small and i need to scale by 100, then scale by 0.01 at the end.

SketchUp doesn’t work very well with two end-points that are within about 0.001 inch of each other. (It doesn’t matter if those two points are directly connected with a single edge, or whether the two points are the ends of two separate edges. Either situation causes trouble.)

The most-often recommended technique to work around this issue with SketchUp is to utilize the so-called “Dave” method (popularized by @DaveR): Place all the relevant geometry into a component. Make a copy of the component off to the side. Scale up that copy by 100X or 1000X (I use 100X). Edit the big copy. The small copy will follow suit. When done with modifications, you can simply delete the big copy with no worry about scaling it back down, jostling its position slightly, etc.

Even when scaled up in such a manner it’s still possible to create very closely-spaced end points, and thus encounter the same problem. But it’s 100X or 1000X less likely, so to speak, that you’ll encounter it in the big version. When I do encounter it, I manually fudge the geometry to share a common point or to separate the two points a bit further, being reasonably satisfied that the fudge will be extremely tiny in the natural-size version.

3 Likes