Cursor probelm in Sketchup Make


I am and architect and have been using Sketchup for many years now. I am having a cursor problem where everything freezes for about 10-15 seconds whenever I click on the cursor to select an object in my drawing. All other features work fine.

This problem has been here for a couple of weeks now and it started just like that. I have deleted Skecthup Make and reinstalled it just recently but the problem persisted. I have also updated Windows 10 thinking that the problem may be generated by the OS but nothing has changed.

Any idea what the problem might be?



It could be a now-well-known issue with Windows 10 updates messing with your graphics drivers. Search this forum and you will find numerous threads about it, some with specific recommendations of driver versions for particular graphics cards. For example

Have you installed any new SketchUp extensions recently? Another possibility is that there is a bug or a conflict in an extension.


I haven’t been able to register for the extensions. I have 4 extensions waiting to be installed. Anything I can do to fix this problem on Sketchup Make?

You need to be using SketchUp Pro.

SU 2018 offers a fix for the slow Select issue.

1 Like

SU 2018? Could you further elaborate?

See @slbaumgartner’s post. He share a link to a thread that addresses the issue you described. There’s a script that can be run with SU2018 to fix the Select tool lag.

Since you are using SketchUp in your practice as an architect, you need to be using SketchUp Pro and since SU2018 is the current version, get it and run the script.

1 Like

Hi. Just downloaded SU Pro 2018 Trial Version to try and fix the select function time lag issue prior to purchasing it. How can I fix the problem? I tried to open a zip file from the link you put in there but led nowhere. Any suggestions?

I’m not sure what you mean by this. The link should lead to a download of a zip file. Unzip that file to get its contents, which is a .bat file. Run that .bat file to apply the patch.

This is what happens: I unzip the files. I click on run the .bat file. I receive a computer harm warning but I run the file anyway. Then the page disappears and can’t find it anywhere.

@ty_s you posted the patch script. Any ideas?

Not sure I understand.

That was to ping the Trimble team member who provided the patch script, not directed at you.

Got it.

FYI: Tried again. Closed Sketchup and ran the .bat. As soon as I click on Run anyway, the window disappears to show the main Windows 10 page.

Ran it again and restarted the software. It worked at the second trial. Thanks!

It looks like I’m late to the party, glad to hear it is working now.

Not at all. Thanks for being there.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.