Ctrl and Shift shortcuts not working in Firefox on Linux Mint

Hey Sketchup friends! I’m encountering a new (to me) issue. I’m running Linux Mint (most current version) and trying to use Sketchup for Web in Firefox (v111.0.1 ). Everything seems to work just fine EXCEPT the ctrl and shift keyboard shortcuts. All the other keyboard shortcuts (at least the ones I use regularly) seem to be working okay. I’ve tried running Firefox with all extensions disabled and get the same result. Ctrl and shift buttons work as expected at all other times on this machine. I also tried to Sketchup in Chromium browser and they worked okay there. I’d rather not have to switch to chromium every time I use Sketchup for Web though. I have no pending updates that I can see and I’ve rebooted several times.

I found a few old threads reporting similar behavior. One suggests trying ctrl+shift or shift+ctrl together. Neither worked. FWIW, below is a command line query recommended in that same thread. I’m relatively new to command line stuff, but this seems to just tell me that I have US english default keyboard settings.

~$ cat /etc/default/locale
'# File generated by update-locale
~$ cat /etc/default/keyboard

'# Consult the keyboard(5) manual page.



Some further searches helped me discover “ctrl+i” in Firefox. I tried that on the Sketchup page, and looked under permissions. For “override keyboard shortcuts” it shows “use default” checked and “allow” as the default. Forgive me if I’m misunderstanding this, but it seems to indicate to me that Firefox thinks it’s allowing sketchup to take over keyboard controls. And sketchup for whatever reason isn’t doing so or isn’t able to. Thoughts? Suggestions?

This topic was automatically closed after 91 days. New replies are no longer allowed.