Create Group from Slice

mac

#1

Creating a group from a slice is a useful function but I find it a devil to use in practice. I haven’t found the right workaround to overcome the unWYSIWYGness of it.

@Box seems to have found the solution here. However, I have not found that always works (probably some step I am missing) but in any case, wouldn’t it be nice if there was an easier way than having to move things around to get at it?

Anyone know the 100% foolproof workflow?


#2

A section cut won’t show anything exactly in plane with the section cut, which is frustrating a lot of times. What I’ve done in the past is to take the group made for the section slice and moving it some minimum amount into the model like 1/16" or 1mm. If you zoom way in, it’s slightly off, but mostly works. I know it’s a work around, but that’s what I’ve done.


#3

I think you’ve said it all right there. I have managed to solve my immediate problem by doing something similar. But wouldn’t it be so much nicer if, say, when you create a group this way, it is automatically stuck to your cursor so that you can move it away or keep it in place?


#5

I’m getting a bit extension heavy now but I’ll certainly give that a go.

I guess the fact that someone has had to produce an extension to solve it speaks volumes.


#6

I’d like to see a setting toggle box for sections for either show/hide in plane geometry as maybe a style setting? It may not be possible or easy with OpenGL, so I don’t know.

Here’s an example image done by the method I described:


#7

I’m not sure I’m understanding the issue, or is it just that you have trouble selecting the group it creates?
If it is right on the face it is sort of hidden in the edges of the other geometry, so use a left to right selection to select it.
Create%20from


#8

As always, you make it look so easy! And it should be but it doesn’t always seem so to me.

I’m not sure I can immediately reproduce the problem I had yesterday but it’s one I have encountered before. I was creating a section, possibly of a group but outside it. If you turn off section view, you can see the outline on the surface of the model but you can’t grab it. As soon as you open the group it disappears completely. Something like that anyway. May be related to not creating the slice inside the group maybe?


#9

That’s because it is outside the context of the group and you probably have hide rest of model turned on.
So naturally you open the group and the other group disappears.


#10

So what workflow would you use to prevent it from happening (if different from what you demonstrated)?


#11

That depends on what you are attempting to do. What are you creating the Section Group for?


#12

In that case I wanted to create a temporary slice through a house in order to work out where things like floor levels would be. I didn’t want to mess up the main model by doing it in place because I thought it would be easier to delete in due course if I pulled it off to one side. It was when I tried doing that that I had the difficulty. Can’t quite remember how I solved it and that’s the problem. I only do it rarely but when I do it’s like the old goldfish round the bowl!


#13

Something like this.
Slice


#14

Or a very different way of using it is to slice something and group it, like this.
Split%20with%20Group


#15

That’s exactly how I expected it to work but you were able to click on the new group and move it. I could see it but couldn’t highlight it. I suspect it is to do with grouping and in what context you create the new group. Perhaps I need an extension that warns you if you try to create a group in the “wrong” context, just as I have an extremely useful one that makes sure I don’t edit a component thinking it is a group.


#16

It’s not that complex.
Do it all from outside any group or component, then when you create the group from slice, before doing anything else, while it is still highlighted, just move it to the side.
Give me a sec.


#17

Here you go, on something a bit more architectural. This retains all the groups and component in the created slice.
Plan


#18

It may also help to know that when you create the Group from Slice, the slice is selected by default. When you create the Group from Slice, you can immediately cut it to your clipboard (CTRL/Command + X). You can then Paste/Paste-In-Place it back into your model as you see fit.

CD


#19

I’ll try to remember that. I have just been trying to reproduce what I experienced yesterday but can’t. Now it’s all working just as I would expect and causing me no problem at all. I must have done something a bit weird I think. Unless anyone else can think of a way that you can create and see a section slice but not be able to interact with it in any obvious way.


#20

If you created it outside a group, then opened the group for editing it would be unselectable.


#21

Here it is in it’s most basic form.
Outside
And as @ChrisDizon mentioned, when created you could Cut it, then open the group and paste in place.