Crash: Icosahedron Skill Builder Scaling Components

Crash: #262987
BugSplat Reported
Icosahedron Skill Builder (2018)
Abundant scaling/rotation problems…mostly learning curve. However, Sketchup Pro did crash. Brief glimpses of “protractor” filling view and returning to normal size during rotation at time of crash. Additionally, scaling Triangle to Pentagon edge was difficult to align “exactly” with Global Axes.
Model Info: Length and Angle snapping disabled. Format: Fractional

Trying to repeat problem…Sketchup Pro latest Release

It is highly likely my keyboard hand was touching/dragging over touchpad on MacBook Pro 15 with 3-Button Mouse connected. Still having scaling/alignment issues.

Is there a question in this?

1 Like
  1. What are best settings (Model Info) for precise alignment of components within a model?

The only setting that might be considered helpful would be to turn off Length Snapping in Model Info>Units. Setting Display Precision higher will help you see small dimensions more easily but it has no bearing on how precise your modeling is. Turning off Profiles in the Style or setting Profiles to 1 is also helpful.

The key thing is to use the various tools like Move and Rotate correctly and to enter values when you know them.

Alignment_Issue_Radial_Array .skp (23.9 KB)

  1. Trying to follow “Icosahedron” Skill Builder (2018)
  2. Scale (Tape Measure) of Triangle side (Component) to Pentagon side (Component)
  3. Overlay Triangle on Pentagon and Rotate Triangle to specific height
  4. Rotate Triangle copies (x4) to form 5-sided “pyramid”
  5. Triangle and Pyramid aligned with Red axis when constructed.
    Is this problem with Bounding Box alignment with geometry? How to check?

The first problem I see is that the triangle you created is incorrect. For a regular icosahedron the faces must be equilateral triangles. Yours aren’t.

And because of that, the resulting structure is too high.

This is how I would start the icosahedron.

A pentagon with the correct side length centered on the origin.(I’ve turned off the axes for the first screen shot. A vertical line from the center and then use the Arc or Pie tool to draw an arc with radius the same as the pentagon side ending on the vertical line.

Draw in an edge to complete the equilaterial triangle which is automatically at the correct slope. Make the triangle a component.

Rotate/Copy to make a radial array around the origin.

EXCELLENT! Scaling two components in model was corrupting other component…and I didn’t catch that. This method avoids that and is perfect for me…Idiot proof :grimacing:

Scale can be tricky for things like this because the scaling box aligns with the axes of the context you are working in. If the component is not open for editing the scale box will align with the global axes. If the component is opening for editing the scale box aligns with the component’s axes.

I assume the default Axes under Make Component is “Global”?..and always in the left corner of the Bounding Box?

No. The global axes are the ones that are displayed even without any components or groups.

By default the component’s origin will be located at the lower front left of the bounding box and the component’s axes will be parallel to the global axes. When you create a component you can choose to set the component’s origin in a different location and change the orientation of the axes if you wish.


If you are curious, click in sequence on the scenes tabs of this SU file for a way to construct an icosaedron without any calculation or guess work.

Icosaedron.skp (93.5 KB)

Thank You. It is interesting. Physically constructed a wooden model decades ago…and didn’t quite understand all the “math” to identify the one “component” that could be replicated 84 times to build all the “3-piece” triangles. (Gluing it together was quite an exercise)

Sketchup was still a dream in someone’s mind back then…Just trying to reconstruct in 3D model what I did in my head a while back with compound mitres. :woozy_face: