Accurately Rotate Scaled Triangle from Regular Polygon Issue with Solid Inspector


Accurately Rotate Scaled Triangles to Meet.skp (18.3 KB)

Screen Shot occurred when Sketchup file saved…I’m Clueless
Rotations appeared to be visually correct.

Zoom in close at the apex and you can see that you missed the rotation by a small amount so the points don’t land at the same spot.

That’s kinda the issue…Zoomed in really close when rotating to intersection point… got “endpoint” at arc and clicked to confirm intersection?
Not aware of how to accomplish this more “accurately”?

In model info>units you have both length and angle snapping enabled. Disable them! (most people have them disabled) They cause many issues with accuracy.

Dang It! While I was fiddling with the “snapping” I turned both of them on and didn’t turn them off. Having a D’OH moment…

If it ain’t one thing, it’s yer mother.

:grin:

Question…What Template Format are you working with?

You mean for units? My default looks like this:

Screenshot - 9_6_2021 , 9_05_06 PM

I’m speechless…Restarted…Switched Model Info to Fractional Format…Enable angle snapping (Check)…and Regular Triangle passed Solid Inspector2…and Scaled Triangle passed Solid Inspector2 with fixes.

I was using Decimal Format…Rotating triangle to Arc intersection with Vertical height was REALLY tedious.

The fractiona/decimal thing doesn’t matter. If you prefer decimal units, go for it. That only affects the way units are displayed.

My default template has units set to Fractional because that’s what I need for much of the paying work I do but it often gets changed to other units for other stuff.

Agreed…But riddle me this: At what “proximity” does Angle Snapping switch off during protractor use?

I don’t know. Never really cared. When the rotation angle is important I either have geometry I can trust for accuracy and precision or I enter the exact rotation angle.