Copying components to new file changes component name

I have drawn cabinets in multiple files. I am now copying them into one file so I can run cutlist.

I have named each component as such : fridge side 3/4" plywood, or sink shelf 3/4" plywood.

When I copy to the new file the component name changes to: side 3/4" plywood. Dropping the “fridge”. Why?

Thanks, Chris

Can you share a couple of example files that show this?

What version of SketchUp are you using? Please complete your forum profile.

cutlist.skp (1.3 MB) laundry.skp (3.1 MB) upper fridge.skp (3.1 MB)

OK, completed profile.

I tried one thing that worked. I went into one of the base files and redrew a component and gave it the same name as the one it replaced. Now when I copy the entire cabinet into the cutlist file it shows the correct name. I would hate to have to redraw every component in my kitchen!


Sketchup make 2017 on my PC

I opened your cutlist file and the upper fridge file. In the cutlist file I deleted the fridge cabinet and purged unused from the file. Then I copied the upper fridge cabinet from its file and pasted it in the cutlist file. It seems to have worked just fine for me.

What process did you use to copy your component into the other file?

I’m curious about why you wouldn’t just have modeled all the cabinets in the same file to begin with. That would save you a bunch of work. Also, do you really intend to use dimensions like these in the shop?
Screenshot - 1_10_2021 , 10_29_40 AM

edit copy and edit paste. I had no idea what purge was so I did do that and now it is transferring correctly. Thanks, there is always something to learn.

I set “model info” to 1/16" increments. Not sure why the x/64" are showing up. Most likely because I changed to 1/16" part way thru the design process and my new lines are attaching to an old line that is in between the 1/16" grid lines. My shown dimensions are all 1/16" or larger.

Next time I will do in one file. I just drew a cabinet and then renamed the file and redrew that one.


I see that actually my base files are 1/16" and the cutlist file was still set to 1/64" so I changed it. I think starting with 1/64" is going to haunt me.

I always work with Display Precision set higher than I will use in the shop. Coarse display precision can mask errors which may become problematic, especially if it creates cumulative errors. One 64th is probably not a big deal but if you get 3 or 4 or 5 64ths in a row, that can be a problem.

Setting Display Precision does not have to haunt you. It can help you detect errors in your model. I use the CutList extension as a quick way to double check for possible errors in models. I don’t expect to see tildes (~) or 64ths in a model. Usually not even 32nds. But if I find any, that raises a red flag to make me check the component. The CutList extension makes it simple and fast to check the entire model.

One thing to understand and remember is that “display precision” means exactly that: the number of decimal places or the smallest fraction denominator that will be shown in the display. It does not mean that your dimensions will be constrained or snap to that increment. It just indicates the smallest increment you want to see on the display.

Seeing ~ in things like dimensions, the entity info window and reports such as CutList means the value shown is approximate; there is a deviation smaller than the minimum set for display precision. This is an almost certain indicator that you are not modeling accurately.

As an explicit example, you can set the units precision to 1/4 inch and then enter an edge length of 5.3768". It will really be drawn to that weird length but will display as ~5 1/2".

There is a length snapping option in model info units, but it also does exactly and only what it says: the length of a line you draw will snap to that increment. It does not imply that you are working on a grid. If the start position of an edge was misaligned, the end position will snap to another misaligned point at some multiple of the length snap away. That leads to accumulated errors that can make a model very difficult to repair. For that reason, most experts recommend that you turn off the length snap option and leave it off! Instead, rely on typing exact values and using inference from known good points to get accurate lengths.

thanks, I am being more careful in using units to set lengths now. But I think a big issue was that I was using the snap feature with 1/64" grid. and when I went to 1/16" grid all those mistakes of snapping worked against the accuracy.

It’s best to turn off Length Snapping. It doesn’t matter what your display precision is, Length Snapping tends to get in the way of creating precise models.