Copy a group from one model into a different model

2016
modeling

#1

I think that I used to be able to copy from one model into a different model before I upgraded to SU 2016, but it no longer seems to work.

I think there are 2 issues here:

  1. Opening 2 or more models simultaneously…my method is to open model “A” in the normal fashion, then open Windows 7 Explorer and go to the folder where I keep all my models, and then double-click on model “B” to open it, and also on model “C” to open it, and so on. Is there a better way to open several models simultaneously??

  2. I previously could could select a group in model “A”, then hit ctrl+C to copy the group, then move focus to model “B” and hit ctrl+V to paste a copy of the group from A into B.
    This no longer seems to work…I’m certainly able to copy the group using ctrl+C, but when I hit ctrl+V in the second instance of SU, the cursor changes but nothing is visible, although sometimes the sidebar shows that the group may have been copied (that is, the sidebar shows “group…3 in model” and after I hit ctrl+V the 3 increments to 4, and then increments again to 5, 6, etc.) However, no actual copies are visible in the model.
    Sure looks like I’m doing something wrong, although it had worked previously in this fashion.

Please help…all comments are very welcome.


#2

It sounds like you are doing something incorrectly. Try the following to simplify the process and see if that works. Open two new SketchUp sessions. In one, draw a cube or a cylinder and make a group of it. Select the group and hit Ctrl+C to copy it. Go to the other SketchUp session and click on Edit>Paste in place. This should put a copy of the group in the same location relative to the model origin as it was in the original file. Does that work for you?


#3

Probably the most simple way to copy from one model to another is to use the Edit, Copy, Paste in Place sequence of commands.

First select the group you want to copy,
Go to Edit > Copy (or use the copy icon in the Standard toolbar)
Navigate to the model you want to place the group into.
Go to Edit > Paste in Place.

That should solve the problem.


#4

As Dave and jvlee have implied, it seems likely that the pasted copy is either outside the viewed area, is too small to see relative to other contents, or is being clipped. Have you tried zoom-extents after the paste? I’m not certain what you mean by “sidebar” but it sounds like the Entity Info panel? If so, it is confirming that the paste happened and your issue is with seeing the pasted group copy.


#5

The importance of the comment by Steve Baumgartner cannot be emphasized enough in this case. The problem may be fixed by doing something as simple as that.


#6

Thanks all for the prompt responses…I think I’ve found the problem, I was attempting to copy a group from SU 2015 into SU 2016 and that did not work…I simply saved the 2015 model as a 2016 save, and after that I was able to copy from one to the other. Problem appears to be solved.

I would like to know if there is another method for opening multiple instances of SU 2016 other than the Windows Explorer method that I’ve been using.

Again, thanks everyone for the informative and helpful responses.


#7

I’m glad to hear the issue was resolved, but a bit of confusion should be clarified. You stated that: you

You can’t save or edit later versions using an older (earlier) version of SU (This means SU2015 or earlier versions cannot read SU2016 files). All releases ARE backward compatible, meaning you can save or edit earlier releases with more current versions.


#8

sorry about the confusion…what I did was to open (using SU 2016) a year old file (that was created with SU 2015). Then I saved it under the 2016 program and all seems to be working just as it should. Thank you for the help…I appreciate your advice.