Coplanar Troubleshooting

I create these types of problems a lot. :tired_face: The why is best reserved for another post. This component has one face that is not coplanar (see GIF). I have turned on color by axis, turned off length snapping, show hidden geometry and set display precision to 1/64". The face is off normal by 10 degrees and bottom angles are 40 degrees (for context).

Is there a way to resolve these types of problems using native SU tools? In the past I believe I found FredoScale to be useful with these types of issues. In some cases, just re-creating the component solved the problem. What techniques have you found useful?

Coplanar-Example.skp (103.0 KB)

You might think that the two end lines being the same coordinate at each end of the line would mean it should be coplanar, but the slope of the bottom line means they’re not. This picture is a similar face shown from the front and side, and you can see that the two long edges are not parallel. Your long edges are also not parallel, but are closer than my example.

I’m not sure if this is the kind of solution you’re looking for but the Rotated Rectangle tool may help.

1 Like

Generally I find it best to avoid creating the non-coplanar edges in the first place. If you followed the basic steps in the video of the step stool, you wouldn’t create the non-coplanar edges.

I would also suggest you save adding materials to your model until after all of the geometry is created correctly.

As you are modeling it, consider the order of operations in the shop. Work in basically the same way.

If you are interested in a cut list from your model, the leg is going to report incorrectly due to the axis orientation.

The way I modeled it, the cutlist would report correctly.

1 Like

Thanks, looks to be viable solution. I just can’t follow all the steps. I get lost at the bottom of the geometry, after selecting rotated rectangle. Not sure what the bottom reference point.

1 Like

A lot of extra steps there. No need for any extensions for this simple thing.

I tried again, a bit slower, no bounding box, no axis. This time without the guide line too.

1 Like

JPP has the option to force the direction of extrusion, with the Plane parameter.

4 Likes

Thank you, @Fredo6 (for everything) , I knew that function, but here is a particular case, because the semicircle must be extruded in another direction compared to the base.

Even if I used an extension (it could be done without), but the face will be exactly the same size, the length will not be shorter.

Slower, worked. Thanks. I have now added “Rotated Rectangle” to my workflow. Now, I just need to determine why/how I am creating these unintended non-coplanar faces.

Oops… Did not see the issue with the rounding… So wrong advice.

Your method seems to be the more accurate.

1 Like

Thanks!

And again thank you very much, @Fredo6, for your extensions, which creates these possibilities for 3D modeling.

Thanks Dave. Interesting point about the axis. How does the axis orientation affect cut list? This is the output. Not sure why the ~3 3/16" happened.

Cutlist extensions use the bounding box of an object to get the dimensions (as if the part is to be cut from a rectangular board). The bounding box always aligns with a group or component’s axes, so if the contents are askew with respect to the axes the bounding box won’t be the tightest fit.

Screen Shot 2020-02-10 at 9.36.36 AM

So, if I change the axes to be coplanar with let’s say, the face, the report will be more accurate? And does this occur with all the cut list extensions?

I can’t claim to have checked every existing cutlist extension, but all the ones I have looked at use the bounding box, which always aligns with the component/group’s axes.

1 Like

slbaumgartner Thanks for your help. My guess is that the approximations in the report would be a result of the off-axes nature of the design.

Cannot tell from the screenshot, but is that due not only to the sequence, but also a change of axis?

Only from the sequence. As in the video you linked to, I created the leg in the vertical position and made the component before I rotated it to the desired angle. This means the component’s axes are automatically aligned so the bounding box fits tightly.

You could change the axis orientation on the component but there’s no need to do that with the method I showed. Just rotate the component after creating it.