Conversion to .dwg Causes Faces to disappear

dwg
sketchup
surface
face

#1

I have a 3D model of a bridge. I’m exporting it to Civil 3D as a .dwg, and the lines are coming through but the faces don’t show up. Any suggestions? I’m a newbie to both programs, so please be detailed. :slight_smile:


#2

Here is some info on that :
https://help.sketchup.com/en/article/3000165
check the part about exporting.


#3

Thanks Mike, I’ve already pored over that article several times but haven’t been able to fix the problem. Anything else I can try?


#4

Are you able to post the file that you have so far? Use the inbox with up arrow icon when you’re typing your reply, to upload a file.


#5

The actual files are too big. Are these screenshots helpful, or no?


#6

I usually get the best result by choosing a low version of AutoCad (v 14), If you have build the bridge in different components ( which you should ) you can save one of them and share here ?
right-click on a component and Save As, then upload here.


#7

Group_53.skp (11.9 KB)
Group_53.dwg (11.9 KB)
Great idea! Here’s a simple column.


#8

No problem here. Export 3D model-release 14. Maybe it is the way you’re importing ?


your .dwg file showed the same.
As it seems, you would have to add data to the mesh in Civil 3D and since they claim to have BIM features, you could classify the sketchup components and export as .ifc ? Haven’t tried it , though


#9

Your AutoCad view is possibly just not displaying the faces as it is set to wirefame. The column you exported imports perfectly into SketchUp. If you switch the view in AutoCad to shaded or other non-wireframe option they should turn up.


#10

He tried to import in Civil 3D , which only display faces that have data attached. No expert, just read the link.


#11

Civil3D is an add-on to AutoCad that doesn’t reduce in any way the functionality of the basic AutoCad running within it. Civil3D adds discipline specific special object types, but that doesn’t stop it supporting standard AutoCad geometry (like the lines that are shown in rbarton’s screenshot). It is the other way round. Civil3D-specific objects won’t display in standard AutoCad without an object enabler, and they cannot be imported into third party applications like SketchUp.

Furthermore, technically, the faces that SketchUp exports are not what the documentation refers to as “surfaces”, but what in AutoCad terminology are polyface objects.


#12

You are correct! Thank you!


#13

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.