Components still stick together after tutorials and forums saying they shouldn't

Sorry if this is an issue that has been covered before… My understanding is that components and groups should not stick together. Attached is a really simple file with three boxes, each created as a component (box1, box2, box3). If I put e.g. box 2 on top of box 1 they stick together. Putting box 3 on top of those makes them all stick together. This doesn’t happen if I either e.g. drag a copy of box 2 from the component library, or if I make them all groups rather than components. What point am I missing?

Thanks!

PaulBoxes test.skp (90.6 KB)

there is a ‘replace selection with component’ checkbox that needs to be checked when you create the component…

john

Hmmm. Why would I need to do this? Why can’t I just make two separate components from two separate boxes and not have them stick? Also have never seen this mentioned anywhere.

You haven’t made them components, you have made components from them but kept them as raw geometry.
If you tick the box on the component creation dialog they will become components. SU will remember your choice until you change it.

OMG, now I get it - thanks to both of you. I don’t recall this being pointed out in various tutorials but perhaps it is. Wonder how many others get confused about this…

The box is normally ticked by default these days, so many don’t have an issue with it. It used to be that it didn’t remember and needed to be ticked every time you made a component from geometry that was attached to other geometry.

1 Like

Looking in the Components Browser, there are but two Components - In Model
In%20Model


Best Practice
To understand what you’re working with, keep the Entity Info dialog open as you’re modeling.


Thanks folks. Yes, having the box ticked as default seems to make a lot of sense and would make it a bit more intuitively obvious…

Once you’ve ticked the box it should remember your setting.

Thanks. I guess the way to think of this is that the geometry you pick creates a component in the component library, but doesn’t generate one in the drawing area unless you explicitly ask it to do the conversion.

By default, if you select all connected geometry and create a component, the component will automatically replace the loose geometry. If you select only some of the connected geometry to make the component, the default behavior is to create the component but leave the loose geometry. If you tick the box for Replace… the loose geometry gets replaced with the component. And this preference is remembered for future components.

It’s probably best to get in the habit of modeling the geometry for one part and make that a component before you move on to modeling the next part. This eliminates altogether the issue you were having and prevents potential problems. For example, here I’ve drawn to boxes side by side but all is loose geometry.

I select the geometry for the left hand one and make a component making sure I replace the selection with the component.

Then I repeat that for the right hand box.

When I move the left hand one away and rotate it, you can see that it has captured the face where the two boxes met. Since that face was added to the first component, it isn’t available for the second.

If the left hand box had been component-ized before even beginning to draw the right hand box, this wouldn’t have happened. The right hand box would be complete.

1 Like

Thanks for the tip Dave. Having looked at lots of threads on various topics I also wanted to say thanks to all you gurus who spend time getting us novices on the straight and narrow path to become better users. Much appreciated!

Paul

1 Like