Component sorting


#1

My components list in the Component window seems to be sorted at random and I see no way to sort alphabetically or otherwise.

So every time I need to insert a component from a big list it’s like an Easter-egg hunt, which is a pain.

Am I missing something?

Paul


#2

In the list I see components are listed alphabetically.
Each new component is placed as expected.
Could you show a screenshot of your ‘In Model’ component list?


#3

The list of components in the model do sort alphabetically. It’s the list from my components library that seem to be sorted at random.

I would send a screen shot but for whatever reason none of those keyboard commands work on my Mac (OSX El Capitan) and when I use Grab the tool palettes disappear so that doesn’t help.

Does the components in your components library display properly sorted?

I wonder if having my library on a NAS is causing the problem?


#4

That’s strange! cmd-shift-4 (= cmd-shift-$ on US keyboard) should start a selection-box screen shot. Is that what you tried?


#5

Yes, It is strange.

I tried all of the ones in Keyboard Shortcuts Preferences…none work, I just get a ding sound.

A bunch of others don’t work either.

Will have to maybe do a clean install of Sierra and see what happens. A root canal might be more fun.

Paul


#6

I am on Windows, and all the components in my libraries appear in alpha order.

BUT,… they appear in order by component property name, not by their skp filename.

I also use text name listing rather than thumbnail image listing (which speeds up SketchUp loading and switching between inspector panels.)


#7

In general my property names match the filename, and I use the file listing
view.

The list is not sorted alphabetically. I upgraded to OS X Sierra and the
behavior persists.

I’m going to move my library off of my NAS and see if that changes anything.


#8

“I’m going to move my library off of my NAS and see if that changes anything.”

Update. After moving my Components library to my local drive, the components sorted alphabetically. Problem solved, sort of. I like having my libraries stored on a mirror and backed up, so now I have to create a cron job to backup to my NAS.


#9

Hello,

I tried reproducing the problem on my macOS Sierra system, but the component library is always sorted correctly (i.e. alphabetically).

Is there anything unique about the NAS volume that you are/were using?

Thanks,
Mark Chandler


#10

Its a homebuilt server running the Nas4free server OS (FreeBSD) so you
would think it would play nice with OSX. Maybe the zfs file system has
something to do with it. Will have to check the settings. the ._files are
still propagating.

I used to keep my library in Dropbox but moved it. It was sometime later I
noticed the problem but didn’t connect the dots. The library isn’t that big
so I will keep it on ma local drive from now on.


#11

Thanks for the info. I’ll be curious to know what you find. I tried various google searches but each hit/link took me to the root of their forums.


#12

This is well after the fact, but take a look at System Preferences->Keyboard->Shortcuts->Screen Shots. That panel will list what (if any) shortcuts are configured for (duh) screen shots.


#13

Steve and Mark,

My last response was wrt the wrong question. Sorry. Different problems.

The keyboard shortcuts in my new Sierra install still do not work. The
screen shot keyboard sequence worked once on the new install and then
nothing. Many of the listed shortcuts in Preferences are now
non-functional. No biggie because I rarely used them anyway, but now that I
am aware of the problem it has me curious.

Similarly, I have a hackintosh running El Capitan as a backup to my only OS
X machine. It’s pretty new, haven’t used it much at all beyond setup.

The screen shot shortcut worked once, the first time, and now anything
related is non-functional. This is true of several of the other default
shortcuts on my main Mac…

I suspect it may be related to the Logitech mouse software I have installed
on both computers, the unifying package. One of these days when I have time
to kill I may revisit it.

I am used to using a multi-button laser mouse for my CAD work, so I don’t
want to uninstall the Logitech preference pane for now. Too busy.

For now I will just use Grab for screenshots. The Sierra version of Grab
lets me choose the output file type, and I prefer .png to .tiff.

Paul


#14

@paulj

Were you able to try other settings to see if that fixed the sorting problem?

Thanks,
Mark Chandler


#15

Once I moved my library from the NAS to the local OS X hard drive sorting
was OK.

Paul


#16

My components went off alphabetical order all of a sudden… maybe when I moved to High Sierra? Not sure. Only today I noticed it and, god, it’s frustrating.
My component library is store locally on my hard drive.


Anybody else still has this issue?
Thanks!


#17

I’m on my phone so I can’t check SketchUp, but it is quite likely this is due to a known change in how High Sierra handled folders vs previous versions of OS X. Finder hides this, but other code sees filenames in random order when it reads a folder directory.


#18

High Sierra seems to randomly sort lists of folder contents - like components.
Previously you got alphanumeric sorting.

This has caused various issues for developers already - e.g. Fredo’s tools relied heavily on scripts’ load order.
Files in the Plugins folder used to load in the alphanumeric order, now they load in a seemingly random order !
I assume that SketchUp [and other affected apps] could force the lists into order without relying on the computer to do it properly [as it has done for years !]
This is another Apple ‘improvement’ we could do without…


#19

From what I read on Apple’s discussions of APFS I think that this is a result of changing the way directories are organized on the disk, from alphabetic order to using a hash scheme. Hash greatly speeds lookup by name, but results in a seemingly random ordering when read as a simple list. They did not revise the low-level library function (readdir) that many C programs use to read a directory, so it now returns the file names in hash order. But apparently higher-level frameworks were revised to handle this change, as, for example, Finder still lists alphabetic order.

In fairness, though, has Microsoft never changed anything in a way that messes compatibility?


#20

With Win10 it seems almost weekly !
But that’s not the issue.
Why change something that’s been the same for years, it is almost certainly going to break some 3rd-party apps.
All OSs rely on such apps to expand their usefulness, so making these kind of major changes should be done very carefully.