Component name change does not take effect

I’ve read a number of posts on this topic but the problem still persists: I designed a house with specialised composit walls. After creating around 20 components which were essentially pre-cut walls, I decided to change the component names to show the thickness of material. So, for example, the previous name of a component was “West Module, West Wall” it now became “West Module West Wall 140MM” as this was the chickness of that particular wall. Despite saving the new name in a Folder called “REV AA SKETCHUP COMPONENTS” and then telling the Components dialogue box on the control panel on the right, it still looks for - and finds - the old component names which I have erased from this Folder. Even if you right click and save each component numerous times, it still finds the old components which no longer exist in the selected folder. Furthermore, if you attach text to each of the components, it gives the old name not the new name

As you can see from the house image there are a number of text labels - none of these names exist in the Folder REV AA SKETCHUP COMPONENTS

Is there any fix for this? Previous forums in 2020/1 highlighted the same problem, but no solution was evident.
Thanks for the help

Hi Dave

No – I use Sketchup Pro 2023. In fact I am running 2 x Sketchup 2023 Pro with different expiry dates which appears to be impossible to fix. I have Sketchup 2017 Free on my profile and it won’t go away. I’ll have to take the issue up with the Australian resellers.

However, the issue I refer to won’t go away. I have deleted all old part names from my computer – or so Sketchup tells me. You can see the difference between Folder REV AD SKETCHUP COMPONENTS in my Laptop on the right, and on the left being accessed through Sketchup. I have tried creating new folder names, but no matter what you do it shows a few from the Laptop, a few that have been deleted and leaves out a whole lot. I’ve tried refreshing the folders on both Laptop and Sketchup – no difference…

Interestingly, when I use the label / Text tool to show the name of a component, it defaults to a component name that I have deleted – see bottom image

Any ideas would be appreciated…

Best regards

Tim Graham

Changes you make to file or component names in an external folder won’t update automatically the components that are in your model.
I would use instance names instead of definition names to identify my parts. In that case every similar component doesn’t have to have an unique definition.

The only way to do this is (via normal user interface) is to rename each component definition in the main model and then save them (rightclick, save as or save as collection)
Or, via script:

Ever since I tried the @TIG plugin, I never use SU native “Save collection as…” (previously called “Save as local collection…”) command again.