Color By Material Style Attribute not Working in Layout V2024

After opening a Layout 2022 file in Layout 2024 and updating the reference to the sketchup file in layout, the color by material attribute is not flowing through to layout. See images attached to this post.


Version 2022 opened in 2024 - not yet updated sketchup file.


After updating the file reference - color by material attribute is lost. No changes to style were made.

2 Likes

Also, the edge color appears missing when exporting a file as DWG/DXF.


3 Likes

This is affect to my workflow, too. Please fix it soon as possible because I’m falling in love with SketchUp 2024. :joy:

1 Like

@Turnervisual

Can I assume that problem occurs in LO when your SU model is being rendered in VECTOR mode?

ChrisD

2 Likes

Hi,
In SketchUp, when you select Color by Material in Edges settings in Styles, then turn off Color By Tag mode, all edges will display with color by tag.
With this style, if you export to 2D DXF/DWG, you will get a CAD drawing with edges have separate colors with SketchUp 2023 and below, but all edges in white color with SketchUp 2024.

And the answer is Vector mode.

@Turnervisual @Cyentruk @curic4su

Let you know that I have submitted your findings to the eng team.

ChrisD

4 Likes

Yes, it’s a problem that only occurs when using either vector or hybrid modes. Raster works but is unsuited to our output requirements.

Thank you all for making us aware of this.
We are currently working on a fix.

Trent

2 Likes

I’m also having the same issue; I’ve assigned 2D lines a colour in SketchUp 2024 via the ‘Colour by Material’ in Style settings, however it doesn’t come across in Layout and everything in Layout just appears black

  • 1 would love an expedient patch for this. Essentially breaks my work flow in 2024.

@Turnervisual @Cyentruk @curic4su

See the latest patch release. The fix is in :slight_smile:

https://help.sketchup.com/en/release-notes/sketchup-desktop-202401

6 Likes

Great, I will check. Many thanks, SketchUp team.

1 Like

After checking, I confirm it’s back to normal. Thank you so much.

3 Likes

@ChrisDizon @trent
Looks like there was a fix for this, but I am still having these same issues.
I always use “Color by Material” for my edges because I think it helps the products (furniture) that I am designing look more realistic. I spend tons of time making these look perfect in Sketchup before sending to Layout. It is so incredibly frustrating that it goes the black edges when using Hybrid mode in Layout. The vector and raster options do not work for my products, so I use Hybrid.
I have updated my Sketchup Pro 2024 and Layout, run as administrator, repair.
Are others still having this issue? Or is the SU team still working on another fix?

Hi elizabeth2, interesting… yeah, this should be fixed in the most current patch release that went out at the beginning of the week. Could you check your About LayOut dialog and let me know what version it says?

Thank you
Trent