COLLADA (.dae) import: texture not showing

Unfortunately, SketchUp won’t import vertex-colored collada files. (I think these are quite common for models created from pointclouds.) So I took the model and used MeshLab to create a pseudo-texture from the vertex colors.
The new file shows up fine and correctly texured e.g. in GLC Player and Open 3D Model Viewer. But, no colors when imported into SketchUp, just the usual shading in white/gray. (I successfully imported other textured .dae files.)

Any suggestions how to get the model into SketchUp with the texture?
Or any suggestions how to properly convert vertex-colored .dae models for import into SketchUp?

Here is the original, vertex-colored model as well as the textured one:

In SketchUp, Sketchup::Vertex objects are not a subclass of Sketchup::Drawingelement, so do not have a material property. Only edges and faces have material property in SketchUp. Vertices are themselves just a geometric “helper” property of edges and faces. They are basically invisible to the user. But the styles can be set to put “Endpoints” where the vertices are. This is just rendering output, though.

Currently, there is no “real” geometric object that could be assigned a “vertex color”. But perhaps in the future, there could be a new render mode called “Color By Vertex”. (SketchUp does currently have a “Color By Layer” mode.)

First of all, SketchUp is a modeler, not a renderer, nor a viewer. Just because some other application can do what you want does not mean because SketchUp cannot, that this a bug in SketchUp. (Removing the tag.)

There are some plugins (extensions) that can create individual gradient textures for the faces that “appear” to radiate from the vertices.

1 Like

OK, but wouldn’t you agree that it would be a benefit if SketchUp would offer more complete Collada support?
Do you have an idea why the textures aren’t imported for this file?

for me your file imported geometry without texture and the image as a material, but it also caused a ‘BugSplat’ for no operant reason…

@Barry I submitted Crash Report #36282


Hmm… socket issue. I tried that file, didn’t crash for me.

But same result: it doesn’t load the png to texture the chair. Opening the collada in on Mac does import the material. Sounds like a bug, I’ll file one, but nothing jumps out to me as to why.

> answered this in the “sister” feature request thread

I did not get a BugSplat. The chair came in. And a material named “<auto>” but it was not applied to the chair.

This material looks just like your “chair_textured_tex.png”.