Changing App Focus Drops macOS Keyboard Commands

Good day Sketchup Community-

I have an issue where I change focus (CMD+Tab) to another app, e.g., my notes to get some measurements, then change focus back to Sketchup. Upon return, I lose the ability to use keyboard commands, e.g., R (Rectangle), P (Push/Pull), O (Orbit), E (Erase), etc.

This is a significant drain on productivity and drag on workflow.

macOS 14.3.1(c)
MacBook Pro M1 Max 64GB
Sketchup for the Web running in a Google Chrome App.

Any suggestions?

Thanks.

-Gedeyenite

yeah, I’ve had this, an it’s in part because of the windows system in mac os.

when you alt tab, you move between the “main” windows of opened apps, and if you have apps with several windows, it’ll open the top one, top one being most of the time the last focused or last opened.

so say, you have 2 safari windows opened, you alt tab to safari, you’ll get the top one / last used in focus.

in SU on mac, most toolbars and side panels are technically independant windows too. close the drawing space, they’ll stay.
in the PC interface, toolbars and panels are sub-windows. they aren’t independent, you can’t close the drawing space and keep the toolbars, it’s all or nothing


what seems to happen is that at times, when coming back to SU, the window that get focused is not the main drawing one. While SOME toolbars and panels dont allow you to ficus them (click on any side panel and it’ll focus the drawing space), SOME like th extended toolbar can be focused.

why the bug then ?
shortcuts only work if the main drawing window is selected. select another one, like the extended toolbar, and you’ll see, no shortcuts.

Capture d’écran 2023-07-22 à 11.15.19
shortcuts (I press space or C and get a tool)

Capture d’écran 2023-07-22 à 11.15.46
no shortcuts. I get the error sound.

I get this situation sometime at start too. if I launch SU and while it’s launching, I check something else, when I go back to SU by clicking the dock icon, the drawing window is not focused. My guess is, it’s the first one to open, and mac os will give me focus on the most recent one, often the extended toolbar.

I usually click at random in the drawing space then, it’s a reflex at this point. Again, it doesn’t happen all the time, I’ve noticed it’s more often if I’m on both screens, but not consistently. I guess some windows have this “focus stealing” behaviour, not all.


I wonder if there is a way to force the drawing window to always be focused (to be considered as “main” one) instead of the top / most recent / last focused one. I’d say probably, since the side panels already work that way, any idea @colin ? (some summer homework for the devs :wink: )

I think a lot of your suggestions may apply to the desktop version.

1 Like

I see the same issue in Safari, and most of the time even clicking on tools or the model space does not bring back the ability to use shortcuts.

@marwanobeidat I tried the steps in a build from last year, and still see the issue on my Intel Mac. On my M1 Mac I get the problem right away in Safari, even without command-tabbing to another application. For Chrome, I get the problem after going to another application.

Oh yes it’s web, completely blanked out on that one.

Just tried on firefox, no focus issue.
But testing this, I found an issue, not really related to this one.

I’ll post it on its own thread