Cant select circle to extrude


I had a box with several holes in it. But I had to change the dimensions of the box so I deleted it (keeping the holes) and recreated the box with new dimensions and extruded it. The problem is that the holes show up but they dont go through the box’s faces anymore! The biggest problem is that I cannot even select the circles to extrude they again, when I click on the circles (on top or bottom view) the Google Sketchip selects the face of the box and not the circles! How can I select the circles? Check the image below, if I click in one circle Sketchup selects the entire face.

See the file attached please, try to select the holes yourself.cruzeta_melhorada_3d.skp (149.8 KB)

Thank you!

They’ve already been extruded. Select all of the geometry, right click and choose Intersect Faces>With Selection. Then select and delete the faces skinning the holes.

Have you tried selecting everything and then using intersect faces with model? That usually works for me. Before you try it, save a backup of the file. Sometimes intersecting faces can have unintended results and having a version to revert to in case of unexpected problems is always helpful.

Also, thank you for posting the file and screenshots! Having those always helps!

Didnt work my friend. I did exactly what you said and the final result was exactly the same that I started. Any other suggestion?

Thanks for helping :slight_smile: I did what you said and unfortunatelly it didnt work. The result was the same before intersecting… in your Sketchup what is the result?

Funny. It worked for me. I didn’t save it but I’ll do it again and post the model.


I just had to extrude it all again (all the holes) but it worked perfectly! It would be nice to be able to do this and keep the extruded holes, but at least now I can continue working in this project.

You are amazing guys, thank you so much!

I tried it too and it worked for me. This is strange. I don’t want to sound like a know it all, but are you sure you did it right?

If you are sure, then can you give me some info about what version of SketchUp you are using, your OS and any plug-ins you have? If this is a bug, tracking it down is a lot easier with more info.

My guess is you didn’t select the already extruded hole walls before running Intersect.

this is what i downloaded.

After selecting all of the geometry. I used a left to right selection box around the whole thing. Triple clicking on the bar won’t get the extruded holes.

After Intersect and deleting the skins over the holes. No extruding done on my part.

yes your approach is much better than mine! I didnt delete the skin over the hole! If I had removed the skin ofver the hole I wouldnt have to extrude the hole again!

You are awesome guys, you explained it all right with a very detailed descritiption.

Thank you so much, I wish you a good day :slight_smile: