Can't save model in SketchUp 2024 - "Save your model to 2020 or earlier to prevent any loss of data"


Hi all,

I’ve been working on a file in SketchUp 2024 and now when I try to save, I get the following error:

SketchUp is unable to save your model.
It is recommended that you attempt to save your model to SketchUp Version 2020 or earlier to prevent any loss of data.

Why is this happening, and how can I go about troubleshooting this? I’m not very experienced in SketchUp and this is the first time I’ve come across this. From a quick search, it sounds like SketchUp 2024 is now “versionless” with no way to save a file to an earlier version. When I try “Save as” I see no option other than saving as a .skp file. How do I proceed here? I’m just leaving the file open in SketchUp for now…

All that I’ve been doing in this file is converting a quick and dirty model of some bookshelves to individual components so I can use the OpenCutList plugin. No new models from 3D warehouse have been added since the last successful save. Nothing complicated that I would assume would cause this error…

Any insight would be greatly appreciated.

Now that’s rich, the error message prompting an export to 2020 when it’s been removed :smiley:

install Dezmo’s tool here

and you’ll be able to export again to older versions.

1 Like

Thanks for the tip. If I save to an earlier version, can I open it back up in SketchUp 2024 and proceed editing with the same file and saving it like normal? Or would I always have to save as an earlier version now?

Does anyone know what to look for in the model that could be causing this?

Here’s the file saved as version 2020 using that extension by Dezmo in case anyone case see what’s going wrong:
bookshelves_corrupt_file_save_2020.skp (14.9 MB)

Well since I saved it in the 2020 version I tried to undo my work until I could get to a point I could save again, and it seemed that it had to do with me editing a component in a weird way? I was trying to create a new component, but accidentally had a pre-existing component selected and in ‘edit’ mode, and had added my new part to that component. I had then undone that somehow and saved the part as its own separate component and carried on editing, until I tried to save and got that error.

In doing the undo/redo to find the exact edit that caused the error, SketchUp crashed and I got this ID: Crash #26269.

When I relaunched SketchUp, I opened my 2020 version of the file, saw the UI dialog mentioning that saving the file again would have some effect because it was from an old version, and then was able to save that file again seemingly without issue, without using the extension. Go figure…

When I’ve seen that error and manage to get the file opened again, the problem would most likely happen again. It would be very useful if you did find steps that made the problem happen every time.

:rofl: do this thing we don’t allow you to do. Having seen this dialogue before I am curious why the old file format would be considered a refuge when the new one fails. I can’t back it up with any statistics but it seems to me there is an increase in corrupt files since the introduction of the new version less format. I wonder if the new file format is somehow more susceptible to corruption?

1 Like

well it’s more compressed, so it wouldn’t be a surprise, compressing stuff can be dangerous.
I also can’t back it up with stats, but pretty much all the broken files we see are coming from windows.
the handful coming from macs are the usual suspects, unpluging the hard drive while working and such.

I suspect that is because the majority of companies with a policy of always storing on a network or cloud also have an IT department that mandates Windows.

plus, when I installed windows 10 back in 2017, it had a “compression option” enabled by default, some files / folders would have a small icon on the side telling me windows had compressed them to optimise storage. it would compress stuff like a picture or a whole movie without asking.

can’t tell you if I turned it off when installing win11 or if it was off by default, but I feel that a compression on top of a compression is not a great thing.

I have noticed that too, some of it is cloud based saving problems but much of it is not

Stuff like that

NTFS compression enabled.

on my previous machine, all I did was training sessions, I would copy from a stick the files, and after a week get rid of them, so I never really had a corrupted file despite the compression.

On my current machine, NTFS compression is turned off. I have 200Gb free right now, there is no need. and after 2 years, still no corrupted file.
(just right click / preferences on your drive in the explorer, and look at the bottom if compression is turned on)

I’d be curious to see how many of these broken files come from compressed computers…

In my case, the issue just stemmed from something I did to my model within SketchUp. I’m on the latest Mac OS Sonoma 14.5 and saving everything locally.

I’ll see if I can re-produce the error, but I do wish SketchUp had logic to just not allow actions that would cause the file to be un-savable…

And after I saved the file as 2020 version, I was able to open it back up in SketchUp 2024 and save without issue (that I could tell).