Can't Put Slab on Top of Foundation

I drew up a foundation for a garage and then tried to put a slab on top of it but Sketchup won’t let me draw it. At first using the rectangle tool it would make the rectangle but not fill in the center it just did the foundation top. when I pulled it up it just extended the foundation walls. I tried a few times and now it won’t even make a rectangle. I end up with a line that goes from corner to corner. I tried to use the line tool and draw the perimeter but it won’t even draw a line… If I draw off the foundation in a open area every thing works fine. Any Ideas on what is going on here?footing.skp (337.1 KB)

Upload the SKP file so we can see exactly what you’ve got so far. I expect there’s an easy answer if we can see it. Otherwise we’re guessing.

Select all the foundation geometry and make it a group or component. Then start to draw your slab.

Added file

Since the foundation is already grouped, you should be able to drag a rectangle between diagonal corners to get the face of the slab. Then pull it up with Push/Pull.

Why do you have the foundation geometry nested three levels deep?

You have ungrouped geometry on layers that are turned off. The new geometry merges with it which creates problems. You are not using layers correctly. Only groups or components should get assigned to other layers. ALL edges and faces must remain on Layer 0. Layers do nothing to create separation between geometry.

I have just started using this so I am learning. I might have to go look for more vids on layers because I understood little of what you said. It would not let me drag the rectangle from corner to corner.

? II solved the slab issue by creating it elsewhere and moving it in place. But I should not have to do it that way of course.

Is there anyway to fix these layers now? Should I go back and delete the layers explode everything and regroup them and put in new layers?

Start here:

No. Of course you shouldn’t. But you do have to do things correctly which means correctly using Layers and grouping geometry.

Definitely do not explode everything. If you’re going to do that, you might as well start the entire model over from scratch.

You can select the ungrouped geometry, reassign it to Layer 0 and then group it.

How do I fidg the ungrouped geometry?

I don’t know what you’re asking.

A group can’t be “on” a layer like in other programs.
It may have some layer other than Layer0 assigned to it. Once you explode the group, all its entities inside that still had Layer0 assigned to them (as should) will now inherrite the exploded group’s layer, something you definitely do not want to. They need to always remain associated with Layer0.
If you don’t yet fully understand the concept of layers in SketchUp, (understandable), you can still create an entire model with foundation, slabs, walls, windows, doors and roof, etc. Grouups and components are fare more importand to start with, … to separate chunks of geometry.

Sorry @DaveR, this was meant for @geehaw.

How do I find ungrouped geometry?

Open Outliner. Right click on the groups and choose Hide. Anything left will be ungrouped geometry. Make sure you have all layers turned on and visible.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.