Can't open an old file - Sketchup states that I have not paid up

Screen Shot 2023-02-15 at 7.19.55 PM

I am paid up but can’t open old models - Need to open urgently!!

Try logging out and then back in again.

I did that a couple of times and on the third time, it worked! You would think that they would have this sorted by now!!

This isn’t a common occurence and when it does happen it’s usually the user’s firewall or other security that turns out to be responsible.

IMO posts about various issues with the licensing system are far too common. There are products on the market where online licensing “just works”.


yes, the main issue is usually that the license hasn’t been applied to the user. it should be automatic. I get that some people manage multiples licences, but then they should have to make the extra step.
This way of doing might be common in high end pro softwares like revit & al. but in an entry-level one like SU it’s super weird. First time I’ve had to do it (apply the licence to myself), and I had to google it, because it was neither obvious nor advertised.

Before @colin comes by and sees this thread, quick question, did you do anything on the computer that may explain it ? recent update of the os or browser, change of firewall, this sort of thing ? judging by your screenshot, you’ve been using since this summer, I suppose it was all ok until today ?

I have done nothing out of the ordinary or changed anything. I tried to open a file that is about six years old, that is it. I did have this happen when I first moved to the pay Sketchup but it seemed to smooth out for while - maybe it is part of opening old files? I am NO expert!

It is set to automatic, but there is an option to uncheck that in the process.