Can't install SU Make 2017

installer
installation
dotnet

#1

I could not get the program to install correctly on one of my laptops. I get the message "Installing Microsoft .NET Framework 4.5.2 (x86 and x64). It just tries over and over. I have tried different browsers as well. Can someone tell me what’s going on?


#2

See the pinned thread by Ty:


#3

How come it worked on the other laptops in my classroom? I downloaded all from the same download page.


#4

Speculation, (because I can’t know without personally comparing it to the others?):

Likely those “other laptops” did not have an issue
with the .NET installation or the VC++ runtime library installations.

I, myself, frequently had installer “hangs” for online MS library installations when triggered by other application installers even back in the Windows 98 days, and since then, I just always got in the habit of cancelling the application installs, then going to Microsoft download, and getting the offline (standalone) redistributable library installers. Then doing the library installs separately.
Only after the libraries are successfully installed, do I then re-run the application installer.

I always did this for all SketchUp versions, and have never had any problems installing any version from 6 to 17, on any system from XP and later. (But then I am a total geek.)

See the following post for direct links to Microsoft download for these libraries.
Download and install them separately.
(But if you have any of the version 14 MS VC++ libraries,
uninstall them, before installing the latest update.)
Reboot, run Windows Update and do any updates to these two libraries.
(Reboot if prompted by Windows Update,)…
Then re-install SketchUp 2017 (right-click "Run as administrator.).


#5

I will be confused if I don’t simply reinstall from SU. I have no SU showing as downloaded to uninstall when I look at the program list.


#6

Sounds like you need an IT technician to do this for you.
The downloaded installers would be in the Downloads folder.


#7

Just to let you guys know, the laptop needed a Windows update, which included an update (optional) for the .NET thing. Once I did that, problem solved!


#8

Microsoft Universal C Runtime Update f. Windows 7/8.x