2017 won't install

installation

#1

When I try to install 2017, I get the following error:

If I ignore this error, another error pops up when I try to run sketchup.

I have a fresh install of .Net 4.6.2, my graphic card drivers are up to date, Sketchup installed the Runtime C++ libraries, I have rebooted, I installed as admin, and yes to all the noob stuff you normally reply with .

Please assist.

MG


Can't install SketchUp Pro 2017!
#2

Manually uninstall ALL builds of version 14 Microsoft Visual C Runtime libraries.

Go to Microsoft download, and re-install the version 14 Update 3 separately.

https://www.microsoft.com/en-us/download/details.aspx?id=53840


#3

Hey Dan:

Nope, didn’t work. I had (2) 14.x.xxxxx versions of Visual C++ installed,
I uninstalled both and reinstalled from the link you sent.

Problem is exactly the same.

Darrell

Regards,
Darrell Norquay - Calgary, Canada


#4

Update on this, Dan, despite the Visual C++ installer saying everything is
OK, it does not show up in my Programs and Features list. Running the
installer again and selecting Repair finishes OK, but still not in the
installed programs list.

Darrell

Regards,
Darrell Norquay - Calgary, Canada


#5

Reboot after uninstalling, and again after re-installing ?


#6

Yes to both. Still not showing up in the Programs and Features list…


#7

When installing the C++, did you get an installer then r-click on installer > Run as administrator?


#8

… which is standard operating procedure when installing anything.


#9

I am logged in as Administrator. Never had to do this with any other install…


#10

You still need to right-click and “Run as administrator”.

I never have issues either, but I also switch off UAC, and always install libraries from standalone redistributable packages.


#11

OK, so I uninstalled VC2105 by running as Admin, rebooted, reinstalled by running as Admin, and rebooted again. Now, at least, it shows up in Programs and Features.

However, the Sketchup 2017 install (run as Admin) shows exactly the same error as before.

Now what?


#12

And is the VC 2015 runtime version 14.0.24215.1 or higher ?


The only other thing (I can think of) to try is to register
the “ThumbsUp.dll” manually from the command line.

REF:


Find the icon for Command Prompt, right-click and “Run as administrator”.
(This is called “an elevated command prompt.”)

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\Dan>cd "C:\Program Files\SketchUp\SketchUp 2017"

C:\Program Files\SketchUp\SketchUp 2017>regsvr32 ThumbsUp.dll

You should see a messagebox like this (hopefully):


Try running SU2017 again,… report back.


#13

Nope, that didn’t work. Says it can’t find Thumbsup.dll. Apparently, thumbsup is a Google written piece of software that allows windoze to display thumbnail previews of sketchup drawings in the preview pane when you are browsing files. Sketchup 2016 properly displays previews, so I can’t imagine how that works but not 2017. Apparently, many programs use it, so some uninstall somewhere probably removed it.

Any ideas?


#14

So, I tried to trick the installer. 2016 has a version of the required dll, and it registers properly. So, I reinstalled, waited for the error box to pop up, copied and pasted the thumbsup.dll from the 2016 directory into the 2017 directory, and hit retry. It worked! Install completed successfully.

But Wait! Dagnabbit! The program still refuses to run and comes up with a new error:

Now what? This is getting really annoying. It’s like the install file is corrupted or something, but I’ve re-downloaded it several times…

BTW, I’ve run sfc and it gives windoze a clean bill of health…


#15

By God! I finally found it!

Apparently there is an update related to C++ redistributable 2015 that must be installed to make this work.

*** Update for Windows 7 for x64-based Systems (KB2999226) ***

I installed this and 2017 fires right up.

Thanks for nothing, guys:stuck_out_tongue:

Just kidding. At least you got me pointed in the right direction.

Still remains the problems:

  • The version of thumbsup.dll supplied with 2017 is potentailly corrupt or incorrect in some way.

  • No indication was given that the 2015 C++ Redist. required this update to function with Windoze 7.

These issues clearly need to be addressed. Hopefully this will assist someone else.


#16

Sorry. There are so many threads with ppl having 2017 install issues.
I most I always say to run Windows Update after doing the separate installs for the C Runtime and the dot NET.

Myself, I had installed that update on the 15th of OCT in 2015 !

The following “pinned” post (in this category) by SketchUp Team memeber Ty, does say that this update is needed.

If you search the forum, you’ll see that the KB2999226 update is mentioned frequently.
https://forums.sketchup.com/search?q=KB2999226


I’m not convinced of this. It works fine on my Win 8.1 machine.

I suggest you restore it. (Perhaps re-run the 2017 installer post KB2999226, and choose “Repair”.)


Glad it is working for you !


#17

FYI, It may have been written when Google owned SketchUp,
but they sold everything to Trimble Navigation in 2012.
This thumbnail handler has always been part of SketchUp.
(Ie, not something you can get and install separately.)


#18

It was there even before. It only worked in 32-bit systems for many years. I think that a 64-bit version only appeared with the 64-bit version of SketchUp

Anssi


#19

I did say “may have


#20

I didn’t want to discredit you - I just let my passion for historical detail to take over.

Anssi