Can't get rid of the greyed out bars (viewport extents) on everything!

Hi All
I’m at work late at night trying to export some still images from my sketchup model.
I’m at the documentation phase of the project and have added dimensions ready for export.
I’m using layout, and scenes which show Left, Right, Front Back elevations and various plans.
When I export either a JPG or a scene to layout (hybrid), I get these large grey bars across the image. They change size depending on output resolution…
The usual method of using TomToms “fix aspect ratio” extension is simply not working in this case. I’ve tried restarting, updating my video drivers (nvidia gtx1080) and everything else I can think of, with no luck.

the model also seems to be suffering from a bad case of viewport clipping, which introduced itself after i began adding dimensions and text.

Would be greatful if anyone can suggest what to try next.

I have nearly 40 extensions (which I use regularly) so unsure if any of these are conflicting.
Link to model:


The bars you show appear to come from Vray and ThomThom’s fix should take care of it but you need to update the scenes fixing. I only saw gray bars along the top and bottom of the image.You could also try the following:

  1. Tools>Advanced Camera Tools>Reset Camera.
  2. Right click on the scene tab and select Update.
  3. Repeat for each scene.

Since the scenes include those gray bars as part of the camera attributes, you have to change the attributes for the scenes by updating them.

I did that and get image exports like this:

I fixed all the scenes and saved it.

1 Like

I was able to ‘Cut’ > ‘Paste in Place’ the content of your model from one SU instance to another, getting rid of the grey bars.
I first window_selected the geometry to do so, then click_selected the imagery of the site.
Strangely three entities stayed behind: dimension 4.7m (front yard?) and text 47.79m2 resp. 43.45m2 (room areas?). I expected to have selected > cut > pasted in place everything this way.

Selecting either the dimension or one of the texts did ‘select’ the grey bars too, but not all the time.

I have no idea what is going on / going wrong. But I suggest to either follow @DaveR’s advice or copy > paste your model to a new SU instance and rebuild the necessary scenes to then properly use LayOut. again.

p.s. I found this text: 50.49 m² quite far from the origin (near ~ -26173,8m, ~ -2747147,9m, 0,0m) that you might want to get rid of. See if that helps.


Thanks Gents,

DaveR; I’d already done that but missed one scene, so when I updated that scene, the grey bars disappeared for all scenes. Strange, but it works now

Wo3Dan; Yes, I’m finding that a lot with my models. When any text is added (associated leader or dim) then the associated line or face is deleted or moved, the text can relocate itself to strange places…sometimes it’s difficult to catch up with it. I do use custom location co-ordinates for my models (they are real places) and I wonder if this influences things? I can’t explain why the text ‘teleports’ to seemingly random places a long way from the model origin.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.