Can't extrude floorplan


#1

I have drawn a floorplan in sketchup, but when I try to extrude it the whole building comes up as a solid, I just want to extrude the walls.


#2

If you place your mouse with push/pull tool active above walls and the whole floorplan becomes selected than lines of your wall are not connected. Try and find where lines did not connect and fix it. Do the first step again and if just walls become selected you fixed it. :slight_smile:
If I misunderstood you please could you share your file so I could see for my self what is wrong?


#3

Thanks for your advice, I suspected that was the case. However I have checked and re-checked where the lines meet and can’t find any breaks. Unless I’m missing something obvious. I haven’t been using sketchup for long, this is my first project and I’m learning it as I go along. If you could have a look at it I would appreciate it, but you will have to let me know how I can share it. Two of the rooms are not extruded with the walls, but 4 are


#4

If the drawing isn’t too big and complicated you could just make it a group and then draw each wall on top of it and pull them up.

To upload an image or .skp file, click the 7th icon from the left, above where you type your replies:

Upload

Or just drag the file into your reply…
If it is over 3MB upload it to Dropbox or Google drive and share the link here.


#5

Thanks for the advice, I will use it if I can’t get the original to work properly. I’m using a web-based application of sketchup, and the model is saved in the cloud somewhere and not on my computer. I’ll try to upload it.


#6

There is a download option available by hitting the folder icon top left. Then attach the download.


#7

54 North Road.skp (282.1 KB)
here is the model


#8

Select all of the geometry, right click on it and choose Intersect Faces>With Selection. You should then be able to extrude the walls.


#9

Thanks to everyone who replied. It’s very reassuring to know there’s a whole community out there that is willing to help.


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.