Cannot see the textures in Sketchup

Hi community.
We are trying with our architect to import to Sketchup a 3d map taken from dronedeploy, which we imported then to Blender in order to import it to Sketchup.
The problem is that we cannot see the textures (material). The textures as you will see, are imported in the program but cannot be viewed (please see the shortcut)

I have looked everywhere but cannot find an answer.
If you know about this it would be a great help if you could tell us how we can fix it.

Thank you so much for your help
Best regards

If you select the imported object what shows up under Entity Info? Currently no object is selected in the screenshot.

1 Like

Hi Greg and thanks for your answer.
I am not sure how to select it. Actually I thought that it was selected.
I clicked again another photo of the textures but nothing is written under entity info.

Is there another way that I can select a texture?

Thank you so much
Best regards

Greg suggested to select geometry (not materials).

  1. To select geometry, activate the Select Tool (toolbar button with black arrow cursor, or spacebar key on keyboard).
  2. Click on the black object in the viewport. Its contours should become highlighted in selection color (usually blue).
  3. Look in the Entity Info inspector dialog in the right side bar:
    • What entity type does it display?
    • Does the entity have a material applied (front face or back face with something other than lilac/white default material)? If the entity type is a Group or Component Instance, it should not have a textured material, otherwise that is the problem.
  4. In case a boundingbox is highlighted around the object, then the object is a group or component and Entity Info displays “Group” or “Component Instance”. Double-click the object to enter into the context inside the component until Entity Info shows entity type “Face”.
    • Does the face have a material applied? It should have a textured material.
1 Like

What type of file did you export from dronedeploy and try to import it into SketchUp?
What type of file did you export from Blender?

If you export OBJ file from dronedeploy and import it into SketchUp using one of the plugins: Universal Importer, Transmutr or Skimp, does it work?

1 Like

Hello @Aerilius and @mihai.s and thank you so much for your replies and effort to help me. I really appreciate it.

The export from dronedeploy was .obc imported to Blender and exported as . stl and .dae in order to import it to Sketchup. I tried as well directly to import it as .obj to Sketchup but I had the same problem.
My architect friend though tried today to export the .obj from Blender as .colada and import it to Sketchup and the result is perfect

So I guess that the simplest solution is to export as .obj from dronedeploy change it to .colada in Blender and import it at last in Sketchup.

Thank you so much everyone. I really appreciate your help and support. You are awesome.
Best regards