Cannot log in to sketchup for schools


#1

I cannot seem to log in to sketchup for schools through g suite
Using Firefox v62 with pop-up blocker turned off


#2

Is there anyone that can help with this issue? I thought I had it handled, but not so.


#3

@BIIS can you confirm the following:

  1. That you are logging in with a G Suite for Education account provided by your school AND
  2. That your school’s administrator has installed SketchUp for Schools from the G Suite Marketplace

#4

I am the administrator and have installed SketchUp for Schools from G Suite Marketplace. I have turned it on for all users in our domain and granted data access.


#5

@BIIS thanks for confirming. Please give us your school’s email domain and I’ll add you to our whitelist


#6

roatanschools.org


#7

Same issue here. The App is deployed in out G Suite for Education domain. The SketchUp for Schools is in the Apps launcher for users. Can you whitelist vms.edu?

Thanks


#8

@BIIS @VMSTechDept all set


#9

I really appreciate your help, but I still cannot log into Sketch for Schools through my Gmail mail page. This occurs when I am using Chrome version 69.0.3497.100 and Firefox version 62.0.3. However when I try using a Microsoft product called Edge, it logs in just fine.


#10

@BIIS Can you send a screenshot of where you are trying to launch SketchUp for Schools from? You wouldn’t typically launch SketchUp for Schools from Gmail, so I just want to understand where you’re running into issues.

What happens when you try logging in at https://edu.sketchup.com/app with your Google credentials from your school’s domain (roatanschools.org)?


#11

This message appears when the page is opening (after I select SketchUp from the list on my gmail page “We encountered a problem with your web browser’s storage support. To prevent loss of data, please save your work frequently and make sure you remain connected to the internet.”

Then I see a dialog box that states “You must sign into a G Suite for Educatin Google account to continue. Make sure SketchUp is allowed to show pop-up windows. (button)Sign in with Google”

When I select Sign in with Google, I see a pop-up window that displays
Moxilla Firefox

https://accounts.google.com/o/oauth2/iframe

And then nothing happens after.


#12

Hi @BIIS please try logging in directly at https://edu.sketchup.com/app with your Google credentials. Screenshots of the error messages you see are really helpful, so please include those. The link you sent is blank, so I cannot garner any helpful info there.

You mentioned this is happening in Chrome and Firefox, but working fine in Edge. Can you send the exact browser versions?


#13

I have the same exact experience when I log directly to https://edu.sketchup.com/app.

Using:
Chrome version 69.0.3497.100
Firefox version 62.0.3.

Microsoft Edge version 42.17134.1.0-This one works OK


#14

Oops. Just tried again in Chrome using the link you provided and it is working. Still not in Firefox though.


#15

Can you whitelist us too? I have G Suite installed and allowed for all users in our domain.

jd.cnyric.org


#16

@phil1 jd.cnyric.org has been added to the Whitelist