Cannot encrypt ruby files using Extension Digital Signature anymore

I have been using the Extension Digital Signature during the last month without any problem, but since last week I cannot encrypt ruby files as I was doing in the past anymore.

I am following the same procedure, even trying with files that previously have been encrypted correctly, and when I sign the extension and download it, the .rbz file is the same that I upload, with no encryption in the .rb files.

I would like to know if any of you are experiencing the same issue. I am registered as a developer, so I don’t think it is a matter of credentials.

1 Like

I moved you to Developers category as it’a the only reason to encrypt Ruby files…

if you can show the folder structure and tell us which zip engine your using, that may help…

I have occasionally had fails, that then worked latter…

john

My structure is:

and inside buhca folder:

I use 7-zip to create the .zip file:

and then I change to .rbz extension:

After that, I upload buhca.rbz in the Extension Certificate Upload Form, check “SketchUp 2016 and later” encryption and sign:


Then I download the certified and theoretically encrypted extension:

Unzipping the downloaded .rbz file, the root file buhca.rb is ok (it is never encrypted), but inside buhca folder I get:

when in previous versions of the same extension I got the correctly encrypted files:

I have tried with previous versions of the same extension that were working before and it is not encrypting either. I hope it is something temporal as you said that occasionally it fails, but I have been trying for several days and it’s still not working.

1 Like

Probably a bug in an update of EW. Thanks for warning the rest of us!

Yeah. Same here.

Should we report the issue?

Please do so! This can’t be intended and could be seriously damaging to developers!

@eneroth3 Is there any specific site to report a bug, or may I just post it in Meta -> Help Center - Report a Problem?

Having the same issue here. Nothing is getting encrypted.
Any news?

Did someone reported it? Still not working.

I just sent a report now. I’ll update if I hear any news.

I reported it few hours ago.

Ok. Thanks.

We are actively looking into this issue and I will post an update once we have one. @Finfa811 I sent you a message, can you please take a look when you get a chance.

Thanks

Jon

2 Likes

Hello all, we have found the underlying cause of these issues and released a patch. Apologies for the inconvenience. Please let us know if anyone continues to have a problem.

Thanks

Jon

4 Likes

Thank you @jon

Trying to upload a script at:
https://extensions.sketchup.com/en/developer_center/extension_signature

And getting this error now:

Site under maintenance
The SketchUp Extension Warehouse is currently under maintenance. We will be back shortly.

How long are we to expect this to be? How short is shortly? Need this service urgently!

1 Like

@frandzel3d It is working now

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.