Cannot add location but can access 3D warehouse

Suddently, I can’t add my location. I can access the 3D warehouse without any trouble.

I feel like I have tried everything. This is maddening. Please help.

Is this in SketchUp 2018? Do you get any sort of messages?

Note that the 3D Warehouse no longer converts models and components to V2018.

If I try to login to sketchup, I get the following message:

Unable to connect. Please check your internet connection.

If I try to add location, I get this:

Add Location requires a connection to the internet and yours appears to be down. Please reset your connection and try again.

This this:

I am not having trouble connecting to the 3D warehouse. I am assuming it’s something else.

Did you try what Colin suggested, anyway.

@colin has there been any change to the Geo-Location service for SketchUp 2018?

No changes. I 100% get the symptoms rwhmur is reporting, if I leave the URL to check as Google. That is, 3D Warehouse has no problems, but add location shows the error about needing to be online. When I set the URL to be https://www.bing.com, add location works correctly.

So, although it’s logical to think that if 3D Warehouse works that add location should as well, that isn’t the case until you change the URL in the i18n.dat file.

Does that mean doing what you directed in the post I linked to should fix it?

Changing the URL worked. Thank you!