Can’t put component on a layer


#1

I have 92 layers in this model. I want to put an item on a particular layer (LandscapeParklet). When I select the object and then click layers in the entity info window I can’t scroll down to that layer. If I use the arrow key to scroll down it suddenly stops and the object is assigned to some layer I didn’t select. If I start typing the name it also stops before it gets to the desired layer and selects some other layer. I’ve tried and tried but I can’t get the object on the desired layer. It seems that this happens when the layer immediately before the desired layer (Landscape) is turned off. When I turn it on then I can select LandscapeParklet.

Any help would be greatly appreciated. Looks like this is a bug.


#2

Right click on your item, choose Entity info, and there change the assigned layer with the layer you want.


#3

Or you might try the Layers Panel in the Extension Warehouse.

With 92 layers, you probably think of them conceptually in groups.

The Layers Panel allows you to organize them in groups, turn their visibility on and off, individually or in groups, expand/contract groups (so your list isn’t 92 items long!), and other neat stuff.

And for this particular purpose, it has a button to “Move Selection to Highlighted Layer” - you make a selection in your model, highlight (in the Layers Panel) the layer you want to assign your selection, then click the button.


#4

Right clicking and opening the Entity Info window is what I did. That didn’t work.
The Layer Panel sounds very good. I’ll try it.