Components are shown in wrong Layer

generate_report
components
layer0

#1

As I read, it is no bug?

The only way to move a component to another Layer is to explode it. But then they are groups and no components any more.

What I don’t understand is why Identity Info shows the Layer the component is moved to. The component should be shown in the Layer it realy is, at least it cann’t be moved.

So, I have to know the Layer before creating a component. What kind of workflow is that?

In behalf of using the Report in SU 2015, I was albe to move all Entities to the correct Layer. Report showed nothing in Layer0, I was pleased, every thing is fine. I am proud having a clean model.

In Report SU 2017 all entities are shown ALSO in Layer0. (I’m not interested in that) They are double listed. What kind of use is this Report.

What happend to SU in the last two Years? Something is going very wrong. I’m so disapointed.


#2

Where did you read that? You can move a component to another layer by select it and then choosing the layer from the drop down list in Entity Info.[quote=“Barbara, post:1, topic:38747”]
What I don’t understand is why Identity Info shows the Layer the component is moved to. The component should be shown in the Layer it realy is, at least it cann’t be moved.
[/quote]

When you select the component, the layer shown in Entity Info is the layer it is currently on.

Except you don’t need to know the layer in advance. In my modeling workflow I usually don’t create any layers until after the model is completed and I’ve decided how I want to show the various components.

Nothing has changed regarding layers in SketchUp over the years. I think you might need to review the way you are using them. Have a look at the Help article on layers in SketchUp.


#3

Hi DaveR,
I’ll post the model for example.
Please tell me how to make the components to be shown in the Layer as shown in Entity Info with disabled Layer Bottom. Play with it and you will understand.

Some components are to be shown in Layer Right, some in Layer Front. Layer Bottom should be disable. Try it.

Fachwerk.skp (581.0 KB)


#4

You’ve got nested components assigned to one layer with the child components inside on another layer.


Clearly if you turn off either the Bottom layer or the Right Layer, the components will not be displayed. Why do you have them organized that way? You can achieve the same thing by assigning the components inside to Layer 0 and leaving just the nested components on the Right layer. Turning off the visibility for the Right layer will take care of hiding them.

Do the same thing for the nested components for the Front.
Fachwerk.skp (554.5 KB)


#5

Sorry, I didn’t get that.

What did I do wrong.
I started creating in Layer0, then I moved everything to Layer Bottom. Then I worked around the corner and it got a bit crowdy, so I made Layer Front and Right and moved, as you said before, the parts to the new Layers.

What is nested where and how do I get them to the correct Layer?

The only way I found is to explode the components, they fall back to Layer0 and then I can move them to other Layers, but they are only groups.


#6

Did you look at my screen shots? I was referring to the brackets as shown there. In the first screen shot I show one of the Erweiterung#1 on the right side selected. It and all of the other instances along that wall are on the layer you named "Right.’ They are nested components which contain two groups, the horizontal and the angled parts. In the second screen shot you can see that the Erweiterung#1 component is open for editing and the groups are selected. You can see they are on the layer called “Bottom.”

If you don’t want those parts to disappear when you turn off the Bottom layer’s visibility, change their layer assignment. I changed it to Layer 0 in the file I uploaded.

There’s no need to explode anything. Just open the component for editing so you can access the groups inside and correct their layer assignment.


#7

Yup, everything is fine now.
so it’s no use to move components with Entity Info. Only in Outliner it takes effect if they are nested.

Now let me understand how to fix all the nested instances Solid Inspector shows me.

I made one component, copied it, made it unique to make changes and copied it again. So all components at least are nested, that means not solid.
How can I fix that or is it not necessary to do so?


#8

What?

Why did you do that?

In order to be solid a component or group must contain only edges and faces and every edge must be shared by exactly two faces. No more and no less. This means no holes and know edges sticking out into space. A component cannot be solid if it contains anything else including other components or groups.

There’s nothing wrong with having nested components or groups. In fact there are many benefits if the nesting is used properly. In your model those nested bracket components are just fine. The only thing you messed up was how you incorrectly assigned the wrong layer to the groups within the nest.


#9

That’s what I did with the components. It didn’t work. That was my problem. The comp is shown in the wrong Layer, because the nested instance didn’t move with it.

To save time… What’s wrong with it? How do you do it?


#10

To me this suggests that you are missing a key idea: the layer associated a wrapper (the containing component) is independent of the layers associated with its contents. Associating an instance with a new layer does absolutely nothing to the layer associations of its contents.


#11

What layer do you want the component to be on? I thought you wanted those bracket components on the right side to be on the layer called "Right and the brackets on the front of the model on the layer called, “Front”. You already have them that way. It’s the groups inside those components that are on the layer called “Bottom” that is causing you the problem. If you want those groups to show even when you turn off the bottom layer, you need to get the groups off that layer. Put them on Layer 0 and leave the components on the Right or Front layer as needed.

Why are you making a component copying it and making the copy unique? What are you changing?


#12

I have to make them unique because the dimensions are different: width and length.
First component is 15x15 thats for the corners. The row of colums are 12x15.
Between the colums under and on top of the window is 8x12. Outliner named the component 15x15#1 … #9.
All theses components move correctly to the Layer I want. Even the window with 3 nested instances of groups and components mixed move correctly.

Why not the brackets? It’ 2 groups made a component.

It’s ok, I know how to fix the Problem, but don’t know what went wrong.
Many thanks, DaveR, for your patient.