Camera Position not working

Hi All,

I have just opened up a model that was developed in the old version and none of the scenes are displaying correctly. All of this worked perfectly in the old version and has been passed into Layout so making changes will require a lot of work as it seems to change the position as well. The scenes are all set up with a parallel camera.

On selecting the scene, it either displays it as a blank screen or zooms in too far and then blanks.

I have to select the Parallel Camera position for it to show up but it has altered the camera position so it is no longer top down. It is at an angle. - see video

I can’t share the model as it is huge.

Any ideas???

Your profile says Latest Vers, is that the very latest version of 2022 that was released as a maintenance release to correct an issue that sounds like what you are describing?

Hi it’s 2022.0.354 which is the latest version

The most recent update has this issue. We’re looking into it. You could use the Look Around tool to slightly tweak the view, or you will need to use an older version of SketchUp.

Thank you Colin,

I have deadlines to hit and this really isn’t helping. I updated the model reference in Layout to see what would happen and it blanks out all the detail in the scene attached to the viewport.

This is hardly a minor issue and should have been picked up in testing. This really isn’t good enough and begs the question what testing do you do before releasing the software?
When will a patch be available for this?

How can I role back to a previous version? Where can I download the previous version?

Will the models be backward compatible?

Thanks Box. From Colin’s response it isn’t fixed.

There was a previous fix that Box was mentioning. That had an unfortunate affect on certain workflows. The attempt to compensate for that introduced a new issue.

As an ex coder and software developer, it still should have been tested before being released.

Dear Colin,

You didn’t answer my previous questions on how to roll back.

I have made a change in LAYOUT adding some additional text.

When I export the jpegs it automatically updates the viewport which has picked up the new broken scenes. How can I undo this and how can I stop it happening??? This has already cost me a day of time that I do not have.

If you still have 2021 installed you would need to do a Save As in LayOut 2022, as a 2021 version file. That will then be able to open in LayOut 2021. The SketchUp 2022 files will open ok in 2021, without needing to save as to an older version.

If you don’t still have 2021 installed there is another difficulty to overcome. The 2021 installer has an issue where it will not let you install or repair if 2022 is installed. The work around to that is to uninstall 2022, then install 2021.

Here is the 2021 installer:

I will check with the developers for any news about the new problem, in the hope that they can suggest an easier solution.

Hi Colin,

Luckily enough I have 2021 still installed albeit I have lost all my extensions. I saved the model as a 2020 version as that is the only open Su 2021 gave me for some reason. The work around seems to have worked so thank you.

However, please put a rocket up whoever is responsible for development & testing. This really isn’t good enough and a TESTED fix needs to be found ASAP.

I mentioned that the SketchUp 2022 files will open in SketchUp 2021, you don’t need to save as to 2020. LayOut is different, the 2022 file would need to be saved as to 2021.

A developer is currently looking at the problem. I’m hopeful he will quickly see what is going wrong.

We made some progress. In the two example files we had that showed the issue, both had hidden elements that were very large. For one it was a set of perimeter edges, that were over 1400 feet diagonally. The other had some map images imported, and hidden. Those had a diagonal of over 1700 feet. In both cases deleting the large items solved the blank scene issue.

Something has changed recently that is affecting how big an area SketchUp can cope with, the developer will track down what is different, and fix things.

For now, anyone having the problem should check to see if there are any very large objects that don’t need to be in the model.

Thanks Colin.

Unfortunately, I do need them in the model.

After my last post someone made a script that can go around the scenes and adjust things to not look blank. Let me know if you want to try that script.