Camera Clipping after creating a few Scenes

After creating 4 or 5 cameras I start getting the CAMERA views clipped and the more I create a camera the larger the clipping becomes until I don’t see anything other than the horizon in all the camera views. See screenshots below. Please advice if there is a fix. This has happened in various models. Thanks in advance.

You’re using the Advanced Camera Tools extension and suffering the result of the frustums it creates.

ACT Frustum


Delete them.
Click … Window > Scenes and create your Scenes with the native Scenes Manager.

Thanks, that works. My question is how do I adjust a scene’s Tilt, Focal Length, Roll. etc. Do I have to create a new ACT then adjust?
Thanks

Look to the top menus and you’ll find … The Camera Menu — SketchUp Help

Use the Camera toolbar and Views toolbar:

Notice the Orbit tool modifier keys in the Status bar at bottom left of the SketchUp viewport.
Hold down Ctrl to ‘suspend gravity’ aka Roll.



Camera Tools by ThomThom — Extension Warehouse
Camera controls without all the clutter created by the ACT extension.

Worth repeating…

Look to the top menus and you’ll find … The Camera Menu — SketchUp Help

Use the Camera toolbar and Views toolbar:


Notice the Orbit tool modifier keys in the Status bar at bottom left of the SketchUp viewport.
Hold down Ctrl to ‘suspend gravity’ aka Roll.


Camera Tools by ThomThom — Extension Warehouse
Camera controls without all the clutter created by the ACT extension.

Worth repeating…

1 Like

Thank you,
I’m sorry I was referring to the camera properties numerical values… Can those be changed in a scene rather they eyeballing them?
Thank you again.

Scenes don’t introduce or modify model settings; they merely save certain model settings.

Try the aforementioned Camera Tools extension by ThomThom

Here’s another camera control extension that may work for you:

CameraControls by Rick Wilson at Smustard.com
Control camera pan, tilt, and roll with sliders and text input (PC only for now)

I keep having this frustrums clipping problem. What is the proper way to delete the ACT cameras? I done the way sketchup suggests in
http://help.sketchup.com/en/article/1219237
but sometimes I can not see the camera object in order to be able to delete it.
Thanks

When you create a Camera using the ACT extension, it creates three Layers.
Confirm the layers are visible, and then Zoom Extents should reveal the frustums.

The frustums may be locked. (Red when selected)
Right click on the frustum > Unlock … then select and Delete

Oh my what a pain, i just discovered this horrible behaviour. Why does Sketchup still include this extension by default?
This has cost me two hours work, and i am just praying i can fix me file.

The view from Camera 3 :

Ok, that wasnt so bad to fix:

  • Firstly i disabled the ‘Active Camera Tools’ extension.
  • restarted Sketchup
  • opened offending file
  • turned on the following layers: “cameras”, “Camera_FOV_Lines”, “camera_FOV_Volumes”
  • zoomed to extents
  • select biggest camera frustrum, and delete the entire object (It will be tagged with “Cameras” Layer)
  • zoom to extents again if you cant see next camera, and continue to delete the cameras.

Your saved views associated with the cameras should still work ( mine did, which made me very happy)

You could just disable Advanced Camera Tools if you aren’t going to use them.

Oops! We posted at the same time.

This has absolutely nothing to do with any of Adobe’s products.

1 Like

ok…

Hi all,

The clipping issue happens to me and trust me I have been trying 3-4hours to fix it but still doesn’t work.

My model worked perfectly fine with animated scenes BEFORE I put in a draped terrain (5mb) which is grabbed from Google and cleaned via Rhino and imported back to Sketchup.

But once the CLEANED TERRAIN is imported, all the scenes are troubled by clipping faces.

I have watched the youtube video about fixing it, have tried moving the whole model to [0,0,0], I doubt if it is because the terrain is too big (20+km from the origin). If that is so, I tried scaling the model down to 1:1000 so it was closer to [0,0,0] - still, clipping exists.

I have also unticked the Advanced Camera Tools in Pro - can’t help.

Will be very grateful if anybody can help and advise some pointers or solution, much appreciated! Thanks.

http://www.filetolink.com/6fd41744e8

Scaling a group or component down actually doesn’t help as the values of the instances are maintained.

Exploding the scaled group or component will help however.

Anyways, I wan’t able to download your model via link.

Clipping is caused by several factors.
Toggle perspective off/on - see if that helps…
Very large geometry also causes it - e.g. modeling a town rather than a block or building…
Your throw away remark of 20km from origin rings alarm bells.
Also scaling down by 1/1000 might still leave enormous components in the model, so it is not foolproof…
Advanced Camera Tools is also best avoided as it makes gigantic hidden frustums in the model, exacerbating the clipping issue…
It can often be a result of some tiny bit of geometry or guide-point miles away from the model’s origin.
Zooming extents and losing the model can reveal that, however having this rogue geometry hidden, or on an off layer or inside an unused component definition can also cause issues, and it’ll be harder to find. Another possibility is that the geometry appears near the axes but a rogue component instance has its origin miles away [sometimes the result of a CAD import etc] - these will often fail to display a good thumbnail in the Model’s Component Browser…


Here's some steps towards a fix, or at least a mitigation... Save the model in case of a mess up... Purge the model of unwanted dross [Model Info > Statistics] Save your desired view to a scene-tab, switch all layers on, switch on View > Hidden Geometry, switch on Guides, switch on axes and reset is not the default set up, set Model Info > Component > Show axes ON... Zoom extents. If you loose the model revert to the scene-tab view. Step through the model's contents to find anything that might be the culprit and delete it. To do this zoom out, try Edit > Select All, then deselect the majority of the model using a fence + Ctrl+Shift, Entity Info will show what's still selected - if it's geometry/guides delete it, if it's a container edit it and repeat the process [use the Outliner to help in this]. If you have component instances displaying wildly distant insertion-point axes you can select each instance in turn and use the context-menu to reset the axes logically back onto its geometry...
You download link requires us to join up. Most will be unwilling to do that. Why not use a free one like DropBox ?

I think one could add sirens and flashing lights to the alarm and not be accused overreacting.


@s.tse,

The model as posted is strewn with unnecessary geometry.
Delete things you don’t need and purge.(like the Add Location terrain hidden below the 20km behemoth.

The 9km x 20km long terrain mesh certainly is the problem.
It might work for long aerial views of the house and site.
But surrounding the house model with 18000 hectares of scenery is definitely crippling for closer scenes.

Consider placing backdrop images near the house for creating your interior scenes.
Or perhaps a cylindrical backdrop as in this example:

Thanks Joseph.

Uploaded the zip file here too
http://www.megafileupload.com/oqUf/20160927_animation01_v8.zip

Thanks @Geo,

That’s very helpful for creating a cylindrical panorama. Am working on it!

Cheers,
S