Both Imperial and metric dimensions

Is it possible to have a sketch that is fundamentally using imperial dimensions ( woodworking), and then detail a part of the sketch in metric, and still be dynamic to changes? Example: a US cabinet door to be made to imperial dimensions, with metric mounting hardware.

Thank you


Yes, with a plugin. It’s something like Dual Dimensions, and by TIG.

See this previous post.

PS. But if you want to have some dimensions shown in Imperial units, and others in metric, I don’t think this plugin is the answer

An alternative workflow would be to set your Model Info/Units to one set (the one with fewest instances of dimensions in that unit), then overtype the dimensions displayed including the unit of measure (mm or cm, say, or inch(es)). Switch back to the ‘majority’ units, and draw those dimensions, accepting what comes up.
If you are not a member of SketchUcation it’s easy to join.
“Register” using the menu link.
There is a free-membership option offered in several links in that page - the first link is in the second line.
A free-member can participate in the forums and download from the PluginStore.
If you pay the modest premium-member fee you will also get freebies, SCF-shop discounts, monthly raffle etc etc…

Thank you. I will follow up on this. Showing them both would be just fine for me. I appreciate the quick response

My US engineering school required we use mks even a number of years ago.
The US space program had a failure cause some folks did not now how to convert??
Even if you convert does the answerer need to come out equivalent to metric ANSI parts?
IMHO you are setting your self to some eventual problem when you start to inter mix system of units in your drawings:slight_smile:

For drawing or scaling you can enter both types of systems (eg: 10mm;20mm in architetal template or 3’;4’’ in a metric template) via the VCB. Dimensions are displayed in one system only.

Hello Ed…
There is a great plugin: "Matt_Toggle_Units"
I use it all the time.
makes a menubar,
where you can easily switch units, precision and formats.

All Dimensions change however,
but you can change
from working in Imperial on the wooden door
and then metric on the hinge.

Try it and see, if this works for you.

Thank you Jakob. I have now been able to try both suggestions that have been made.

DualDims does the job of showing both types of units, and can be invoked on a single dimension, or a selection of dimensions, but once invoked, those dimensions are FIXED, (not dynamic anymore), and if I am still moving things around in the design, then I must erase them, put back in dynamic dims in the system units, etc. This plugin is perfect for final documentation, but appears to make it more cumbersome during design. I hope I am using it correctly.

“Matt_Toggle_Units” does exactly what you said. Changes all dimensions in the model at once, but they remain “dynamic”.
This is the best choice for moving things around and positioning them bouncing back and forth between imperial and metric. Very nice.

Once I have the pieces done, then I can use Dual Dims on selected dimensions, and print the drawings to the shop. It is very obvious which dimensions are meant to be measured in the shop in Imperial or metric because the are almost always in nice even numbers in one system or the other.

The suggestions that you all have made allow me to achieve what I was looking for. Maybe someday there will be a plugin that combines the benefits of both of these for this type of application use.



Hello Ed…Good to hear…!

When you have finalised a piece,
Any change in the text, removes the “dynamic” and makes it fixed.

You can mark the Dimension with one left mouse click,
then right click and choose edit text.
Then, type the value again without any unit and press enter.
The dimension is now changed from dynamic to fixed.

You can, likewise, turn off “show units”…
edit the dimension and add a unit yourself.

I once saw a fine video about dimensions…
I believe it was a Sketchup Help video…?

PS: Many users dimensiom their work in “Layout”…
a part of the pro version.

Enough for now,
Spring Greetings Ed…
Good luck with your models…

Hello Ed…I found the video about dimensions…!
SketchUp Skill Builder: "Dimensions"

It shows how you can change the text, keep the dynamics, or lock it.
A simple way to have both types present.

Spring Greetings…Jakob.


While looking for something else, I came across a plugin by Jim (Foltz) on SketchUcation plugin store, called Scene Units.

This allows you to save model units specific to the scene.

I haven’t tried it, but the description suggests that you could have one scene with dimensions (which take their units from the SU setting) in metric, and another in imperial units, or even different scenes with different units in the same type of measure - say feet in one, or inches in another, or decimal vs fractional.

And potentially keep both associated, so if you change the model the dimension should update.

As I say, I haven’t tried it, but for your purposes it sounds potentially useful. If you do try it, could you post results here?

Hmmm. Well, it has a problem - doesn’t seem to work in SU2017

EDIT: on Mac but does work on Windows.

I get these ruby console errors when first clicking on the Scene Units v1.0 entry in menu Extensions, then clicking again on the Scene Units sub-menu.

Error: #<NoMethodError: undefined method `enabled?' for JF::SceneUnits:Module>
/Users/JohnWMcC/Library/Application Support/SketchUp 2017/SketchUp/Plugins/jf_scene_units/main.rb:15:in `block in <module:SceneUnits>'
SketchUp:1:in `call'
Error: #<NoMethodError: undefined method `toggle' for JF::SceneUnits:Module>
/Users/JohnWMcC/Library/Application Support/SketchUp 2017/SketchUp/Plugins/jf_scene_units/main.rb:13:in `block in <module:SceneUnits>'
SketchUp:1:in `call'

@jim_foltz, is there any simple fix you or I could apply for this error? Is it a function of the latest SU using a different version of Ruby?

EDIT: Further experiment gets me the same errors in SU 2016 and 2014 on Mac.

Have had a brief PM correspondence with @jim_foltz and found a fix for Mac, where I was getting an earlier error that I hadn’t properly registered:
Load error: no method 'platform_win'.

Line 26 of the main.rb code in his plugin reads:

      elsif Sketchup.platform_win == :platform_osx

It SHOULD read

      elsif Sketchup.platform == :platform_osx

With that change, the plugin works on Mac. And it also worked in another test on Windows 7 in a VM running SU 2016.

I expect Jim will fix the original on the Plugin Store when he has time - he’s busy at work today.

1 Like