Black modelling space

Hi there,
just downloaded Sketchup Pro and when we open we get a black modelling space./ everyrthing else seems to be there. Just cant see what we are drawing. hope this is an easy fix
BTW It is downloaded on to an HP Spectre with plenty of juice

In SketchUp, go to Window>Preferences>OpenGL. Untick the box for Use Fast Feedback. Does that change anything?

Success. Thanks very much Dave.

Happy that helped.

FWIW, while your computer may have “plenty of juice”, this indicates the GPU doesn’t. If you can replace it with a better one, it would help.