Beginner at SketchUp, trying to create THESE shapes

advice
modeling

#1

Hi guys, :slight_smile:

Hi, I’ve been using Sketchup since about 1 month now, had maybe 25 hours with it.
I’ve gone through most all of the official SketchUp YouTube tutorials (very useful by the way!) and decided I wanted to make something grand! (like all beginners probably do!)

So I googled around churches, found this great Monastery in Moldova. No lie, the right-hand structure in my screenshot took me about 6 hours! much learning curve! anyway, embaressment aside…

I’m trying to create the thing in the photo circled red. So far I’ve only ever worked with straight edges, flat surfaces (apart from the archway), but that was easy because of the brilliant circle and arc tools.

So the thing Im creating in the pic is a bit more organic… my first approach was… create square block, draw some arcs on it, and then somehow erase the edges to create that curvature. But very quickly learned that won’t work.

I don’t know how to exactly describe the shape in the photo, so I don’t really know what to google.

So can anyone recommend a method? How would you do it?

I’m sure it’s just one of the many problems I have yet to overcome with this model!!!

I’m enjoying Sketchup, but as with anything you learn… depending HOW you learn, depends how well equipped you are to go out in the wild with your techniques… (I had no books, just YouTube tuts from SketchUp official channel). The 4-part intro videos were brilliant for me, but after that, I just pecked around the skill builder vids. sometimes they were tutorials (carry out this action…) a bunch of steps. I would usuuallty just repeat what the teacher did and hoping it would sink in when I came to do it for a purpose (ie this model).

Any tips welcome guys!
Thank you for reading!


#2

Draw the arced face.
Pushpull it the desired depth.
Group it.
Select it.
Copy it (edit Copy)
Paste In Place (edit menu)
(It should be selected.)
RotateTool -> rotate about the center 90deg
Intersect the two groups into one group (Use OuterShell if you have Pro)
Move into place at top of column
Intersect with column (if desired)


#3

You can also model this by intersecting a hemisphere, a cube, and a plane (adjust the circle at the top to match the diameter of your column):


#4

Thanks jimhami42,

This is the ideal shape.
Any way I can download this GIF as a movie!?>

I want to be able to carry out the steps but it can’t be paused! :smiley:


#5

#6

Legend! Thank you!
I’m also a bit impressed by the sorcery! - did you always have this as a movie file, and went ahead and GIF’d it for me?

I subbed to the channel by the way!


#7

Actually, it was the other way around … I recorded it as an AVI and saved it as a GIF. When you asked for the movie, I saved it as an MP4 and uploaded it to YouTube. I’m using Screenpresso which does a better job at MP4s than it does with compressed GIFs.

I hope you will share your monastery results.


#8

I will do! Assuming i finish it!
Might have bitten off too much for a first project!

My brother in law works in post production so I’m hoping i can send him the files and have him render it, so trying to model as cleanly as i can.

I used to work for a team who make 3d worlds, so I’m hoping over time i can create more and more, form a portfolio of sorts.


#9

Hey folks,

I’m having another problem with my modeling of the Caprian Monestary.

I’m creating the door of the building which has quite a nice circular window design at the top of it.

I have a polygonal (tall, vertical) which is the door surface. upon which I’ve drawn a circle, divided it into 8 segments plus a central circle.

So I think those lines are drawn against the suface of the polygonal column (the door surface).

I want to push pull the divisions in the circular window to recess them a bit, but everytime I select them one by one, the entire wall (door surface) is selected also (as seen in the picture).

I noticed that the lines themselves are bold, which if memory serves from my learning, there is still a gap somewhere and the lines are not joined up, thus creating an individual surface.

Before now, I’ve done things like 'intersect with model, which seems to fix things (some of the time!), but I can’t seem to make these segments individually selectable.

What am I doing wrong?

ps- sometimes I wish there was a ‘free-select’ tool, (think photoshop), because numerous times trying to fix this, I’ve drawn a circular select around the circular window and annoyingly also selected parts of the archway above it (which i didn’t want to do).


#10

You should be using groups or components to separate geometry into contexts that will not interfere with one another.

Also you can use the CTRL key to toggle the addition or subtraction of objects from the selection set, whilst the SelectionTool is active. (Pay heed to the help text displayed on the status bar. It tells you what the tool modifiers are for the native tools. You can also open the Instructor panel in a tray of it’s own [I have a “Help” tray just for the Instructor panel.] And then you can have it hovering around or on an second display, etc.)


#11

Hi Dan, thanks for the advicings! :slight_smile:

I’ve been using groups here and there, for instance on archways, those are grouped.

I’m away from my desk right now but I’m guessing, from what you’re saying, I might be able to select the outlines of the window area and group them.

I think I need a closer look at the model again to see how it’s constructed. (Haven’t worked on it in a few days).

In theory, if I draw a bunch of connected lines on the surface of an 8sided polygon, I should be able to just push pull and create indents into a face on the poly.

Something’s gone wrong and I was tired (end of day!) trying to work it out! I’ll take another look!

But about the bold lines, I think I might need to read up again what hey actually mean, because I thought it meant they were lines which weren’t properly connected, but some of these lines definitely ARE connected (closed), I can tell that, because I’m able to select the area inside of them.


#12

They are “profiles”. Sort of like lines on the horizon of the object, as you view it. So those edges that are “profiled” will change as you orbit around the model. “Profiled” means having the profile style applied.

You can see the profile width setting via the Styles panel.
Select the “In model” style collection (little house icon)
Click the the “Edit” tab.
Click the “Edge Settings” icon.
Then you’ll likely see that profiles are active (checked) and set to some number of pixels higher than 1.

All that said, having profiles thicker than other edges is really a presentation setting and normally is not needed for modeling. Making SketchUp render profiles can slow down orbiting on very large models.

In my default (custom) template, I have 3 scenes premade. They are “Work” (where I model), “Print” and “Thumbnail”. Each scene has it’s own style (which uses the same name as the scene.) All 3 are quite different. The print scene style is all black and white with sketchy edges (like a charcoal pencil.) The thumbnail scene styling is shaded with textures but plain lines with profiles. The Work scene styling is plain lines no profiles, shaded on, textures off, xray on. In addition the camera of the work scene is expected to change at any time, and does not matter as I never use that scene for output, or Layout viewports, etc.

See the User Guide chapters on styling:

and


#13

I said basically 2 things.

You use the CTRL key to add or subtract objects from your selection set (usually made via a window select, aka fence select.)

I mentioned groups and components because the native selection tool can only select items from the current editing context.
So if you had double-clicked to enter into the editing context of an archway, then you could not select any entities outside that context. So, then the entities collection of groups and components serves to filter your selection ability just by their geometric separation. (Which is one of their main purposes.)


#14

I was mostly aware of those concepts. Thank you for your advice.

Perhaps I can send you the working file ? I’m sure whatever it is causing the problem would be obvious to an expert.


#15

Hello SkillipEvolver,

I just happened to be working on a Moorish style minaret for practising my skills and might be able to help out as this problem sounds very familiar to me. Just send me a copy of the file and I’ll quikly have a look :slight_smile:


#16

@maxim1731 very greatful for the offer of help, thank you. Eventually I sorted it.

It turned out that the surface I was drawing the circular window design on was actually rotated by a couple degrees . So… when I was drawing the circular design, I thought I was drawing it directly flat onto the surface but in fact it was floating a little bit in front of it,

This is something I’m definitely needing to get better at within SU. Along with moving objects into place too. I am there like a loonie trying to nudge things into position. Very amateur. And, I must learn which axes the arrow keys correspond to. I’m wasting an awful lot of time nudging things in the wrong direction.

Back to the problem… I ended up drawing another octagon and drawing the circular window again from scratch. I then grouped that entire door (with window) and moved it into place on the original octagon (pretty much).

My next problem, and I know it will be!! (As I’ve already tried), will be creating the next chamber. It’s cylindrical (easy enough) but it has a polygonal shape projecting from it. I’ve had a couple go’s creating it but I find it tricky.

This is the shape:

I could create a basic octagon around the cylinder and intersect the two (if the octagon had a basic shape, like say… (top of castle shape) (square wave)


|| ||

but it has a more tricky darted ‘v-shape’ (highlighted in picture)
What would be the best way to attack it, guys?


#17

Hey there, anyone who’s reading…

I hate to appear needy, and this is just a leisure project for me… But does anyone know how I could create the shape above? ( in the picture).

I break it down logically as a cylinder, and an octagonal polygon, with the cylinder being on the inside. But the problem I’m having trouble thinking through… Is how to model those V-shaped areas (highlighted).


#18

It is just an octagon inside a square. (However it looks like the octagon is not “regular”. Ie the corner sides appear a bit larger than the others.)


#19

Thanks @DanRathbun, I’ve decided just to make each face of the octagon the same dimensions (for sake of ease).

Having a bit of an issue getting the projected styling to work right. (on top of that,I had that infuriating 'save your work multiple regularly, but SketchUp crashes and you lose it bug).
It’s pretty ridiculous in my opinion. Instead of complain, I will research it on this forum. But honestly, it is pretty silly.

I remember having the same issue with the very first archway i ever did in this model, but I can’t remember how I got round it.

Problem is this area:

I’m pretty sure I employed FollowMe to nail it the first time round, but here’s what’s happening for me when I try it now:

Any clues folks?


#20

okay, well then you’d:
Draw a square and group it (at least temporarily.)
Draw guidelines across the midpoints of the square’s sides to locate the center.
Then draw an octagon centered inside it (tapping CTRL key to orient flats along sides of square.)
Move the octagon up along the z axis (press UP ARROW to lock movement to blue axis.)
Then draw edges from the vertices of the octagon to the corners of the square.

(When the square is no longer needed it can be deleted.)